summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-shell-integration
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/kitty-shell-integration')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest6
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.0.ebuild34
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.1.ebuild34
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild34
-rw-r--r--x11-terms/kitty-shell-integration/metadata.xml20
5 files changed, 128 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
new file mode 100644
index 000000000000..8c18b70fc67e
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -0,0 +1,6 @@
+DIST kitty-0.24.0.tar.xz 4503616 BLAKE2B 5a42b4815d25ff9e3a1f9fb6673e4e58ec3b59b5f81dc4098ef24408580d070e92a181e84167f5a343ffc3a9af33556823153d463eaa8e406f31c032ed8bab37 SHA512 b851ed56d16f9a39d47810bf27c2bc8cbb52d476376c4090045db90c1ad0bc7db6fd9e97edd6ce50a6d69e716671e1e909aab889ecac368857ad5c07f68a76af
+DIST kitty-0.24.1.tar.xz 4512652 BLAKE2B ea1bf4911a744fb5aaa5fe3d9fc4821880e78c60a0a89ecba12c73623b9b537c2d9d4e494da125669f2fc36f273f49a00cc5825f56184c1b0c69f4c570b2226d SHA512 e590a3abd4ed38ce956ee1e1b9d3679150c83b80df5ed9daf9773d7a278f63dc8a3a563058906d322f9186bece7d479036a502864fd80f45593c4970c056f389
+EBUILD kitty-shell-integration-0.24.0.ebuild 1341 BLAKE2B 82d41d989852db434fcb8eb0716880d4aa68b57c23d66af5c0a65ec784c0102f194edd8471e97f0352f0cb68747c6390dd694aa965608a9fd1ec852b7287b3df SHA512 a8b4b8988a9d0fa6ba2c2d690c3ee065a7efc3ee4c7f00b8c089f841a4ca0c7b3c72bf86a07e605440d19592db143ad0df0f13de1e1a070298e00e07e0bbe4d3
+EBUILD kitty-shell-integration-0.24.1.ebuild 1341 BLAKE2B 82d41d989852db434fcb8eb0716880d4aa68b57c23d66af5c0a65ec784c0102f194edd8471e97f0352f0cb68747c6390dd694aa965608a9fd1ec852b7287b3df SHA512 a8b4b8988a9d0fa6ba2c2d690c3ee065a7efc3ee4c7f00b8c089f841a4ca0c7b3c72bf86a07e605440d19592db143ad0df0f13de1e1a070298e00e07e0bbe4d3
+EBUILD kitty-shell-integration-9999.ebuild 1273 BLAKE2B 141961e4dd944b18a87b9eed23a66d414585079e2d80a1677584a59959dd56c2bc827a4dd18b255b1571d97efbfddd77f97fdd494713cd07cd513b79bd79ff8b SHA512 84a4ed1442f18c857d4770e08ab28a8e4fc37c227499cdd1a190e6347382f4df3f3b8c6c62799d1a00b4c5390f2c2249809a2aa9f47844e23a8bda9f8179cf10
+MISC metadata.xml 610 BLAKE2B 29a121e206c4a21965f03cac1b01314dc32384eb617e9c188814f2c9a8896d10cb299aa4ef7fec74c5a74c966069355d291fe23d9f37b2cbb3d34ebb24850f81 SHA512 867c3bfc752f53287bea2f027a949bb433cd069f5480a5197986371db6dac4524577bf1503259a4fb4f6832ec7c860a5f2b4ac495a17c6a19fee5c62a70e6892
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.0.ebuild
new file mode 100644
index 000000000000..fc3c61131372
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+}
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.1.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.1.ebuild
new file mode 100644
index 000000000000..fc3c61131372
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+}
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild
new file mode 100644
index 000000000000..4bf3e29efd4b
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+}
diff --git a/x11-terms/kitty-shell-integration/metadata.xml b/x11-terms/kitty-shell-integration/metadata.xml
new file mode 100644
index 000000000000..60597e252fe3
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>pabloorduna98@gmail.com</email>
+ <name>Pablo Orduna</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">kovidgoyal/kitty</remote-id>
+ </upstream>
+</pkgmetadata>