summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-shell-integration
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/kitty-shell-integration')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest2
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.34.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 6977264fe1bc..c227ce26524b 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,6 +1,8 @@
DIST kitty-0.32.2.tar.xz 8103024 BLAKE2B 637449eb655973700493f725846263bfba193729725b6f14490fc44872e191c5e47b272bc3955b5ca47d400a497931be0749d338354ae8a5402fd867f7b941d3 SHA512 245d399366c0b2174bb80d557c08edf49e96a034a3cf33d2027180ef418581cc9bea2566d9ead9f96094bdc01655aeddd251b07b1bc444e7af59c864eb2bcd01
DIST kitty-0.33.1.tar.xz 8166164 BLAKE2B 6592ae99f3e05bda5367186096804175f00f21770e7112bf45fa968d161e70d2fdcf956214e29e048e6973ee14457f5eaca753a761824f1c104ba32552122e33 SHA512 5fa2421baf9fac41d4a8ff89bb5e44d1820012e8c960e25980d597dcebbb44ffa97c03818e8a91015691321eedb9d9f53139a97cbb6bd673053fbfd73c77739b
+DIST kitty-0.34.0.tar.xz 8227440 BLAKE2B 8e5b27d095a73711995f5f9c7b320e13632893ae3040204d643e5fe29a98c0337aff3abd4aa91300c84fa8fc435a077beddbbec123937b6db29a2c2f3fb1e89c SHA512 310084af59fb5832c9b87961d278601a8408fdcf4500083ffa5d4980ae600a2122a7477be23bfe0c374dec7955707894cb74cfd550ae577d66e39ed2e8b9c0f8
EBUILD kitty-shell-integration-0.32.2.ebuild 1494 BLAKE2B 03057c85fa0e54a6dfa4a45b2ed80a7c83a6e5a122c0089993317bdc537228b4a4c17e53a4e7dd89ea71ff3b9301f6cee8a742e206067aeb8e80c2cbbddf2373 SHA512 277f6b5298edfa91b73fa487b76957303f303db79a88a4f57bb6f712b03a6bcc3b69f29e7903e1638a6cd31e5830d6961c264735219072965858567d92424911
EBUILD kitty-shell-integration-0.33.1.ebuild 1495 BLAKE2B cf96ff7723dc790117f8ac92a86a3f204db05a41c1dec34cdfb09b15ef9c31745166fa17ca14d3dbe7613bd6ae185e1284466d955493226dfad7de522b16ab65 SHA512 e01ea21c08c9e77820b7a84c1a36c03e3787ffa54283b9a034a94e58193e74cb2a4ed8e6ef4e7667371281c959ac7d0b27fd13360bae3878c679b6e8ef466c93
+EBUILD kitty-shell-integration-0.34.0.ebuild 1497 BLAKE2B 945f2dc0f841bc3570f6d9c5a01a70c60f826fe8c1cf4ba402bf5478ca956e4578dbf356a98198eef51d90e403a98478feb20cddd91cb94ccbe3c2b51d39b2a4 SHA512 fa959b05abd969e137baccf58b0465cd2ce0b150abf2d377d54b9b86615cf93c4dd0691688fb62f59c619b14577a015b28897da435ee088ec26a41c97b9f2bfd
EBUILD kitty-shell-integration-9999.ebuild 1408 BLAKE2B f3310f49863e8dbd3c4e1ea27ac5c2ed7ae9f4840262a9fa155b24bc8545e99bcd7931f86bcec51a2c161a6e59e4bce24c26e7a028a96a6f7c9fbdcc0d02d791 SHA512 572a4946fb8511fc70c0fb461763c63dffe69c0985458e8234688796bba908bb7c84d24516556dd500bc9dd3c31d12a440c0a8dddc5300ea96ae2156c9a10a4e
MISC metadata.xml 610 BLAKE2B 29a121e206c4a21965f03cac1b01314dc32384eb617e9c188814f2c9a8896d10cb299aa4ef7fec74c5a74c966069355d291fe23d9f37b2cbb3d34ebb24850f81 SHA512 867c3bfc752f53287bea2f027a949bb433cd069f5480a5197986371db6dac4524577bf1503259a4fb4f6832ec7c860a5f2b4ac495a17c6a19fee5c62a70e6892
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.34.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.34.0.ebuild
new file mode 100644
index 000000000000..c3b309c79626
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.34.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}