summaryrefslogtreecommitdiff
path: root/x11-terms/gnome-terminal/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/gnome-terminal/files')
-rw-r--r--x11-terms/gnome-terminal/files/3.42.2-fix-build-with-meson-0.61.1.patch39
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-3.44.1-fix-missing-wexitcode.patch21
2 files changed, 21 insertions, 39 deletions
diff --git a/x11-terms/gnome-terminal/files/3.42.2-fix-build-with-meson-0.61.1.patch b/x11-terms/gnome-terminal/files/3.42.2-fix-build-with-meson-0.61.1.patch
deleted file mode 100644
index e0e9d39204f2..000000000000
--- a/x11-terms/gnome-terminal/files/3.42.2-fix-build-with-meson-0.61.1.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-https://github.com/GNOME/gnome-terminal/commit/9a168cc23962ce9fa106dc8a40407d381a3db403
-https://bugs.gentoo.org/831940
-
-From: Christian Persch <chpe@src.gnome.org>
-Date: Fri, 14 Jan 2022 11:33:32 +0100
-Subject: [PATCH] build: Fix for newer meson
---- a/data/meson.build
-+++ b/data/meson.build
-@@ -18,7 +18,6 @@
- metainfodir = gt_datadir / 'metainfo'
-
- i18n.merge_file(
-- gt_dns_name + '.metainfo.xml',
- input: gt_dns_name + '.metainfo.xml.in',
- output: '@BASENAME@',
- po_dir: po_dir,
-@@ -27,7 +26,6 @@ i18n.merge_file(
- )
-
- i18n.merge_file(
-- gt_dns_name + '.Nautilus.metainfo.xml',
- input: gt_dns_name + '.Nautilus.metainfo.xml.in',
- output: '@BASENAME@',
- po_dir: po_dir,
-@@ -40,7 +38,6 @@ i18n.merge_file(
- desktopdatadir = gt_datadir / 'applications'
-
- i18n.merge_file(
-- gt_dns_name + '.desktop',
- input: gt_dns_name + '.desktop.in',
- output: '@BASENAME@',
- type: 'desktop',
-@@ -57,4 +54,4 @@ meson.add_install_script(
-
- # Subdirs
-
--subdir('icons')
-\ No newline at end of file
-+subdir('icons')
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-3.44.1-fix-missing-wexitcode.patch b/x11-terms/gnome-terminal/files/gnome-terminal-3.44.1-fix-missing-wexitcode.patch
new file mode 100644
index 000000000000..aff2237db902
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-3.44.1-fix-missing-wexitcode.patch
@@ -0,0 +1,21 @@
+https://gitlab.gnome.org/GNOME/vte/-/issues/72
+Someone already tried to upstream a similar patch to gnome vte that
+would fix this but was rejected by maintainer. More info can be found
+on the link above.
+
+W_EXITCODE is missing in musl thus causing gnome-terminal build to fail.
+This patch checks if W_EXITCODE is not defined and then defines it.
+--- a/src/terminal.cc
++++ b/src/terminal.cc
+@@ -47,6 +47,11 @@
+ GS_DEFINE_CLEANUP_FUNCTION0(TerminalOptions*, gs_local_options_free, terminal_options_free)
+ #define gs_free_options __attribute__ ((cleanup(gs_local_options_free)))
+
++/* fix for musl */
++#ifndef W_EXITCODE
++#define W_EXITCODE(ret, sig) ((ret) << 8 | (sig))
++#endif
++
+ /* Wait-for-exit helper */
+
+ typedef struct {