summaryrefslogtreecommitdiff
path: root/x11-plugins/wmweather/wmweather-2.4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmweather/wmweather-2.4.4.ebuild')
-rw-r--r--x11-plugins/wmweather/wmweather-2.4.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/wmweather/wmweather-2.4.4.ebuild b/x11-plugins/wmweather/wmweather-2.4.4.ebuild
new file mode 100644
index 000000000000..84e2c5d4ece3
--- /dev/null
+++ b/x11-plugins/wmweather/wmweather-2.4.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+DESCRIPTION="a dockable weather monitor for standard METAR stations using ICAO location"
+HOMEPAGE="https://people.debian.org/~godisch/wmweather/"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libICE
+ x11-apps/xmessage
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+S=${WORKDIR}/${P}/src
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ../{CHANGES,README}
+}