summaryrefslogtreecommitdiff
path: root/x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild')
-rw-r--r--x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild b/x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..2951a537833d
--- /dev/null
+++ b/x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="a weather application, it shows the weather in a graphical way"
+HOMEPAGE="http://wiki.colar.net/wmfrog_dockapp"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+S="${WORKDIR}/Src"
+
+DOCS=( ../{CHANGES,HINTS} )
+
+src_prepare() {
+ default
+ emake clean
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" INCDIR="" \
+ LIBDIR="" SYSTEM="${LDFLAGS}"
+}