summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild')
-rw-r--r--x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild
new file mode 100644
index 000000000000..28f7c2dbaecf
--- /dev/null
+++ b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Pidgin IM Encryption PlugIn"
+HOMEPAGE="http://pidgin-encrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pidgin-encrypt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 sparc x86"
+IUSE="nls"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ >=dev-libs/nss-3.11
+ net-im/pidgin[gtk]
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-glib2.32.patch"
+)
+
+src_configure() {
+ strip-flags
+ replace-flags -O? -O2
+ econf $(use_enable nls) --disable-static
+}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}