summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-bot-sentry
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-bot-sentry')
-rw-r--r--x11-plugins/pidgin-bot-sentry/Manifest5
-rw-r--r--x11-plugins/pidgin-bot-sentry/metadata.xml17
-rw-r--r--x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild30
3 files changed, 52 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-bot-sentry/Manifest b/x11-plugins/pidgin-bot-sentry/Manifest
new file mode 100644
index 000000000000..de0da08efd39
--- /dev/null
+++ b/x11-plugins/pidgin-bot-sentry/Manifest
@@ -0,0 +1,5 @@
+DIST bot-sentry-1.3.0.tar.bz2 280673 SHA256 e65581328a508a82cd32d246f4037ea3b044eafd223c3c967947f847db28e736 SHA512 ec665eee2f9b64eccabd10116cb1d1e4be046bc9a6132cb815373be915d265b29b33d41298047f82f920f5daac70a966169ecb201450ba47d76d090c581ee788 WHIRLPOOL 1a52d09188c5838f352b87b09066d563c9ad37e6d38145ebb32178a62b3ba69395f067cca785b5ec70c0458e642872e2f6ae511967481bc19ef0f9d93e5adcfc
+EBUILD pidgin-bot-sentry-1.3.0.ebuild 655 SHA256 46e1e2c3790f335f6095ffc2d876ef5b2a4efacb7018947248e3979dee15195b SHA512 fb5b61b2dcf0a4f116bc703c1c8fea09ea86a94ae04f3de888764e16b3a6e1981193416ed00cadad6add27553d8abb2e47dd42558f6903dfb32cd5764ea94f8c WHIRLPOOL 49f703bfd7256f49146b82fa5c3e710aea646195def2355c4bd82155d57aeaa19832270d3afcf53a711beffa453b4fe81c8555601880d0fd3bcceb82db7f538a
+MISC ChangeLog 2209 SHA256 1edf61fdedef6137782f9106e08174e2b6a8f9b188444894a4830ddc81f5dde8 SHA512 a34d7b21bdd3ae216da2be7dc2af237f6ae940d64241ecf44708be3a305bc20f3cf741c6c96494bed76ba0eb6703dac9a8643527f3fe67320dd50d496da6f9f1 WHIRLPOOL aba14939d243d0e20fbca8b2be2f2c6a107cf450665d9645b1a85fd96483b09a6ac651dd79b06baa72c12b7aabed64efd8797a85fc14ac20e2ffcb0921955f42
+MISC ChangeLog-2015 793 SHA256 6258945aedfbcbcca9d3be542ec227cf8d92dec77af9a335099d142eb79f48da SHA512 2724a82a19838868388c5f9d420288fb3566a4bebd988373a8de56589cab318c88154d6182b4c20b5d57ab305f0f0f58875590a559f260e6a6dfe89b0d90e02a WHIRLPOOL 75399cd98ee3aa32e9a67e80269164cf8a235d7bfec064dc09618589c7b1dab13d08b6a84f1a5e54a441196c5b0d18d55b111f7d5a66cc2fcaf9adcc2f688581
+MISC metadata.xml 639 SHA256 058f5905b792ad357167c2b05bbbce9bac1ded201bd3a12b3ec6a43271673573 SHA512 90febd229b516ad4504d865ba317666fa5fa2981cc3404c58c08cc331787e4980b134c29915604382a8b8495ea33a38b1cd42c4a7fb8e6841d25e95b0c5f8e34 WHIRLPOOL dfd0d71d6993c55095de18a881766b594f505eb446c6ab92db9bb21d645cc7f2f988a1af8d920ae1dd3a58bf0c62cbc413e427bd5077c41e429b1841184b5e97
diff --git a/x11-plugins/pidgin-bot-sentry/metadata.xml b/x11-plugins/pidgin-bot-sentry/metadata.xml
new file mode 100644
index 000000000000..0171dd0ebc91
--- /dev/null
+++ b/x11-plugins/pidgin-bot-sentry/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <longdescription lang="en">
+ Bot Sentry is a Pidgin (libpurple) plugin to prevent Instant Message (IM)
+ spam. It allows you to ignore IMs unless the sender is in your Buddy List,
+ the sender is in your Allow List, or the sender correctly answers a question
+ you have predefined.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pidgin-bs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild b/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild
new file mode 100644
index 000000000000..848cafaec1f4
--- /dev/null
+++ b/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+inherit eutils multilib
+
+MY_P="${P#pidgin-}"
+DESCRIPTION="Bot Sentry is a Pidgin plugin to prevent Instant Message (IM) spam"
+HOMEPAGE="http://pidgin-bs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pidgin-bs/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}