summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0-r1.ebuild')
-rw-r--r--x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0-r1.ebuild b/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..7588bf87e5a5
--- /dev/null
+++ b/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${P#pidgin-}"
+
+DESCRIPTION="Bot Sentry is a Pidgin plugin to prevent Instant Message (IM) spam"
+HOMEPAGE="https://sourceforge.net/projects/pidgin-bs/"
+SRC_URI="mirror://sourceforge/pidgin-bs/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-util/intltool-0.40
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}