summaryrefslogtreecommitdiff
path: root/x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild')
-rw-r--r--x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild b/x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild
new file mode 100644
index 000000000000..ed50957c7417
--- /dev/null
+++ b/x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A web monitor plugin for GKrellM2"
+HOMEPAGE="http://gkwebmon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+# The Makefile links with -lssl.
+RDEPEND="app-admin/gkrellm:2[X]
+ dev-libs/glib:2
+ dev-libs/openssl
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cc-cflags-ldflags.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+
+ emake CC="$(tc-getCC)"
+}