summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r3.ebuild')
-rw-r--r--x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r3.ebuild b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r3.ebuild
new file mode 100644
index 000000000000..b3affa03f88b
--- /dev/null
+++ b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A mixer control plugin for gkrellm"
+HOMEPAGE="http://gkrellm.luon.net/volume.php"
+SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa"
+
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-reenable.patch"
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-r3-pkgconfig.patch"
+)
+
+src_configure() {
+ PLUGIN_SO=( volume$(get_modname) )
+ default
+}
+
+src_compile() {
+ tc-export PKG_CONFIG
+ use alsa && local myconf="enable_alsa=1"
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" ${myconf}
+}