summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild')
-rw-r--r--x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild b/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild
index 541296313c57..5f7915f98273 100644
--- a/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild
+++ b/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild
@@ -1,28 +1,29 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="A minimalistic GKrellM2 plugin to control radio tuners"
SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
HOMEPAGE="http://gkrellm.luon.net/gkrellm-radio.php"
-DEPEND="lirc? ( app-misc/lirc )"
-RDEPEND="${DEPEND}
- app-admin/gkrellm[X]
-"
-
-IUSE="lirc"
-SLOT="2"
LICENSE="GPL-2"
+SLOT="2"
KEYWORDS="~amd64 ppc sparc x86"
+IUSE="lirc"
-PLUGIN_SO="radio.so"
-S="${WORKDIR}/${PN}"
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ lirc? ( app-misc/lirc )"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/${PN}
PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+PLUGIN_SO=( radio$(get_modname) )
+
src_compile() {
use lirc && myconf="${myconf} WITH_LIRC=1"
emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" ${myconf}