summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellm-mailwatch/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellm-mailwatch/files')
-rw-r--r--x11-plugins/gkrellm-mailwatch/files/2.4.3-0001-Respect-LDFLAGS.patch36
-rw-r--r--x11-plugins/gkrellm-mailwatch/files/2.4.3-0002-Use-gkrellm_gkd_string_width.patch29
-rw-r--r--x11-plugins/gkrellm-mailwatch/files/2.4.3-0003-Remove-a-few-more-GCC-warnings.patch41
-rw-r--r--x11-plugins/gkrellm-mailwatch/files/2.4.3-0004-Do-not-force-O2-in-CFLAGS.patch28
4 files changed, 134 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-mailwatch/files/2.4.3-0001-Respect-LDFLAGS.patch b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0001-Respect-LDFLAGS.patch
new file mode 100644
index 000000000000..158357dc4855
--- /dev/null
+++ b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0001-Respect-LDFLAGS.patch
@@ -0,0 +1,36 @@
+From 139912e0cf5d9714e5e1fe4576d01251491701f5 Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <jim_ramsay@dell.com>
+Date: Mon, 1 Nov 2010 08:36:17 -0400
+Subject: [PATCH 1/3] Respect LDFLAGS
+
+Instead of using a non-standard varible name like LFLAGS, using LDFLAGS
+lets this play nice with Gentoo's build system.
+---
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index b8cf927..02ca376 100644
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,7 @@ INSTALL=install -c -m 755
+
+ CFLAGS += -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(GKRELLM_INCLUDE)
+ LIBS = $(GTK_LIB) $(IMLIB_LIB)
+-LFLAGS += -shared
++LDFLAGS += -shared
+
+ LOCALEDIR := $(DESTDIR)/usr/share/locale
+ PACKAGE ?= gkrellm-mailwatch
+@@ -30,7 +30,7 @@ all: mailwatch.so
+
+ mailwatch.so: $(OBJS)
+ (cd po && ${MAKE})
+- $(CC) $(CFLAGS) $(OBJS) -o mailwatch.so $(LFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(OBJS) -o mailwatch.so $(LDFLAGS) $(LIBS)
+
+ clean:
+ (cd po && ${MAKE} clean )
+--
+1.7.3.1
+
diff --git a/x11-plugins/gkrellm-mailwatch/files/2.4.3-0002-Use-gkrellm_gkd_string_width.patch b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0002-Use-gkrellm_gkd_string_width.patch
new file mode 100644
index 000000000000..7edff1c74990
--- /dev/null
+++ b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0002-Use-gkrellm_gkd_string_width.patch
@@ -0,0 +1,29 @@
+From c9db9953296709ba3c86a7b0471fcd60469225ed Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <jim_ramsay@dell.com>
+Date: Mon, 1 Nov 2010 08:43:17 -0400
+Subject: [PATCH 2/3] Use gkrellm_gkd_string_width
+
+This wrapper is designed to transition from GdkFont to
+PangoFontDescription. Without it, there is a warning and a probable
+runtime crash, as we are feeding the wrong structure into
+'gdk_string_width'.
+---
+ mailwatch.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/mailwatch.c b/mailwatch.c
+index 3f0f0a2..5cca01e 100644
+--- a/mailwatch.c
++++ b/mailwatch.c
+@@ -608,7 +608,7 @@ update_plugin(void) {
+
+ p->statstext->x_off =
+ gkrellm_chart_width() -
+- gdk_string_width(p->panel->textstyle->font,
++ gkrellm_gdk_string_width(p->panel->textstyle->font,
+ buf) -
+ 2 * gkrellm_get_style_margins(p->panel->style)->left;
+
+--
+1.7.3.1
+
diff --git a/x11-plugins/gkrellm-mailwatch/files/2.4.3-0003-Remove-a-few-more-GCC-warnings.patch b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0003-Remove-a-few-more-GCC-warnings.patch
new file mode 100644
index 000000000000..5cc76c6fc828
--- /dev/null
+++ b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0003-Remove-a-few-more-GCC-warnings.patch
@@ -0,0 +1,41 @@
+From 873186988c7b7cbde50d1f44ad0e745ddadf0e18 Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <jim_ramsay@dell.com>
+Date: Mon, 1 Nov 2010 08:44:17 -0400
+Subject: [PATCH 3/3] Remove a few more GCC warnings
+
+These are mostly harmless, but no harm in cleaning them up.
+---
+ mailwatch.c | 5 +++--
+ 1 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/mailwatch.c b/mailwatch.c
+index 5cca01e..fcb77a8 100644
+--- a/mailwatch.c
++++ b/mailwatch.c
+@@ -198,7 +198,7 @@ check_mh(Mailbox * mbox) {
+ return TRUE;
+
+ /* Check the unseen mail */
+- while (fgets(buf, sizeof(buf), f), !feof(f))
++ while (fgets(buf, sizeof(buf), f) && !feof(f))
+ if (!strncmp(buf, "unseen", sizeof("unseen") - 1)) {
+ found = 1;
+ break;
+@@ -444,12 +444,13 @@ plug_expose_event(GtkWidget * widget, GdkEventExpose * event) {
+ static gint
+ button_release(GtkWidget * widget, GdkEventButton * ev, Mailpanel * panel) {
+ gchar *command;
++ int retcode;
+
+ if (panel->command == NULL)
+ return FALSE;
+ command = malloc((strlen(panel->command) + 4) * sizeof(char));
+ strcpy(command, panel->command);
+- system(strcat(command, " &"));
++ retcode = system(strcat(command, " &"));
+ free(command);
+ return FALSE;
+ }
+--
+1.7.3.1
+
diff --git a/x11-plugins/gkrellm-mailwatch/files/2.4.3-0004-Do-not-force-O2-in-CFLAGS.patch b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0004-Do-not-force-O2-in-CFLAGS.patch
new file mode 100644
index 000000000000..828c9dd2d5f4
--- /dev/null
+++ b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0004-Do-not-force-O2-in-CFLAGS.patch
@@ -0,0 +1,28 @@
+From 68bd98eb4144ce1f784e9c7aee4735a3f668453e Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <jim_ramsay@dell.com>
+Date: Mon, 1 Nov 2010 10:11:30 -0400
+Subject: [PATCH 4/4] Do not force -O2 in CFLAGS
+
+Only uses -O2 if the user has not specified any CFLAGS in the
+environment.
+---
+ Makefile | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 02ca376..c4ca35c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -10,7 +10,8 @@ GKRELLM_INCLUDE= -I/usr/local/include
+
+ INSTALL=install -c -m 755
+
+-CFLAGS += -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(GKRELLM_INCLUDE)
++CFLAGS ?= -O2
++CFLAGS += -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(GKRELLM_INCLUDE)
+ LIBS = $(GTK_LIB) $(IMLIB_LIB)
+ LDFLAGS += -shared
+
+--
+1.7.3.1
+