summaryrefslogtreecommitdiff
path: root/x11-plugins/fsviewer/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/fsviewer/files')
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch21
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-fix_title_bar.patch62
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc-10.patch26
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch11
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch36
5 files changed, 0 insertions, 156 deletions
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch
deleted file mode 100644
index 2d1759fefce5..000000000000
--- a/x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- fsviewer-app-0.2.6.orig/configure.ac 2007-10-13 23:54:47.000000000 +0200
-+++ fsviewer-app-0.2.6/configure.ac 2015-09-02 21:10:40.829519545 +0200
-@@ -26,15 +26,15 @@
- dnl look for X windows first so further libs check
- AC_PATH_X
-
--if test "$x_includes" != "NONE"; then
-+if test "$x_includes" != "NONE" && test -n "$x_includes"; then
- CFLAGS="$CFLAGS -I$x_includes"
- fi
--if test "$x_libraries" != "NONE"; then
-+if test "$x_libraries" != "NONE" && test -n "$x_libraries"; then
- LDFLAGS="$LDFLAGS -L$x_libraries"
- fi
-
- dnl Additional "default" items
--#LIBS="$LIBS -lX11"
-+LIBS="$LIBS -lm -lX11 -lXpm"
- #CFLAGS="$CFLAGS -I/usr/X11/include"
- #LDFLAGS="$LDFLAGS -L/usr/X11/lib"
-
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-fix_title_bar.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-fix_title_bar.patch
deleted file mode 100644
index 36f595609375..000000000000
--- a/x11-plugins/fsviewer/files/fsviewer-0.2.6-fix_title_bar.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-diff -Naur fsviewer-app-0.2.6.orig/src/FSFileView.c fsviewer-app-0.2.6/src/FSFileView.c
---- fsviewer-app-0.2.6.orig/src/FSFileView.c 2007-10-14 21:06:02.000000000 +0200
-+++ fsviewer-app-0.2.6/src/FSFileView.c 2015-09-02 21:18:39.574691303 +0200
-@@ -430,7 +430,7 @@
- WMResizableWindowMask);
- attributes.window_level = WMNormalWindowLevel;
- attributes.extra_flags = GSFullKeyboardEventsFlag;
-- attributes.flags = (GSWindowStyleAttr | GSWindowLevelAttr |
-+ attributes.flags = (/*GSWindowStyleAttr |*/ GSWindowLevelAttr |
- GSExtraFlagsAttr);
- WMSetWindowAttributes(fView->dpy, WMWidgetXID(fView->fileView),
- &attributes);
-diff -Naur fsviewer-app-0.2.6.orig/src/FSFinder.c fsviewer-app-0.2.6/src/FSFinder.c
---- fsviewer-app-0.2.6.orig/src/FSFinder.c 2006-07-23 09:24:16.000000000 +0200
-+++ fsviewer-app-0.2.6/src/FSFinder.c 2015-09-02 21:18:39.574691303 +0200
-@@ -144,7 +144,7 @@
- WMResizableWindowMask);
- attributes.window_level = WMNormalWindowLevel;
- attributes.extra_flags = GSFullKeyboardEventsFlag;
-- attributes.flags = (GSWindowStyleAttr | GSWindowLevelAttr |
-+ attributes.flags = (/*GSWindowStyleAttr |*/ GSWindowLevelAttr |
- GSExtraFlagsAttr);
- WMSetWindowAttributes(finder->dpy, WMWidgetXID(finder->win),
- &attributes);
-diff -Naur fsviewer-app-0.2.6.orig/src/FSViewer.c fsviewer-app-0.2.6/src/FSViewer.c
---- fsviewer-app-0.2.6.orig/src/FSViewer.c 2007-10-14 17:29:04.000000000 +0200
-+++ fsviewer-app-0.2.6/src/FSViewer.c 2015-09-02 21:18:39.574691303 +0200
-@@ -161,7 +161,7 @@
- attributes.window_level = WMFloatingWindowLevel;
- attributes.extra_flags = GSFullKeyboardEventsFlag;
- attributes.flags =
-- (GSWindowStyleAttr | GSWindowLevelAttr | GSExtraFlagsAttr);
-+ (/*GSWindowStyleAttr |*/ GSWindowLevelAttr | GSExtraFlagsAttr);
- WMSetWindowAttributes(fsViewer->dpy, window, &attributes);
- WMAppAddWindow(fsViewer->wmContext, window);
-
-@@ -189,7 +189,7 @@
- attributes.window_level = WMNormalWindowLevel;
- attributes.extra_flags = GSFullKeyboardEventsFlag;
- attributes.flags =
-- (GSWindowStyleAttr | GSWindowLevelAttr | GSExtraFlagsAttr);
-+ (/*GSWindowStyleAttr |*/ GSWindowLevelAttr | GSExtraFlagsAttr);
- WMSetWindowAttributes(fsViewer->dpy, window, &attributes);
- WMAppAddWindow(fsViewer->wmContext, window);
- }
-@@ -216,7 +216,7 @@
- attributes.window_level = WMFloatingWindowLevel;
- attributes.extra_flags = GSFullKeyboardEventsFlag;
- attributes.flags =
-- (GSWindowStyleAttr | GSWindowLevelAttr | GSExtraFlagsAttr);
-+ (/*GSWindowStyleAttr |*/ GSWindowLevelAttr | GSExtraFlagsAttr);
- WMSetWindowAttributes(fsViewer->dpy, window, &attributes);
- WMAppAddWindow(fsViewer->wmContext, window);
- }
-@@ -476,6 +476,7 @@
- bindtextdomain("FSViewer", getenv("NLSPATH"));
- else
- bindtextdomain("FSViewer", LOCALEDIR);
-+ bind_textdomain_codeset("FSViewer", "UTF-8");
- textdomain("FSViewer");
-
- if (!XSupportsLocale()) {
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc-10.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc-10.patch
deleted file mode 100644
index 00c5e651e69c..000000000000
--- a/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc-10.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -Naur fsviewer-app-0.2.6.orig/src/FSViewer.c fsviewer-app-0.2.6/src/FSViewer.c
---- fsviewer-app-0.2.6.orig/src/FSViewer.c 2007-10-14 17:29:04.000000000 +0200
-+++ fsviewer-app-0.2.6/src/FSViewer.c 2020-02-03 00:20:37.979716353 +0100
-@@ -25,6 +25,8 @@
- static Bool focusIn;
- int ModifierFromKey(Display *dpy, char *key);
-
-+WMUserDefaults *defaultsDB;
-+WMPropList *filesDB;
- void
- wAbort(Bool foo)
- {
-diff -Naur fsviewer-app-0.2.6.orig/src/FSViewer.h fsviewer-app-0.2.6/src/FSViewer.h
---- fsviewer-app-0.2.6.orig/src/FSViewer.h 2006-07-23 09:24:15.000000000 +0200
-+++ fsviewer-app-0.2.6/src/FSViewer.h 2020-02-03 00:20:39.299718025 +0100
-@@ -123,8 +123,8 @@
- } CallbackRec;
-
- /* Application defaults */
--WMUserDefaults *defaultsDB;
--WMPropList *filesDB;
-+extern WMUserDefaults *defaultsDB;
-+extern WMPropList *filesDB;
-
- /* all Panels must start with the following layout */
- typedef struct PanelRec {
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch
deleted file mode 100644
index 2a532625ff8c..000000000000
--- a/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- fsviewer-app-0.2.6.orig/src/list.h
-+++ fsviewer-app-0.2.6/src/list.h
-@@ -29,7 +29,7 @@
- #ifndef __LIST_H_
- #define __LIST_H_
-
--#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
-+#if defined(__GNUC__) && !defined(__STRICT_ANSI__) && (__GNUC__ < 5)
- # define INLINE inline
- #else
- # define INLINE
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch
deleted file mode 100644
index da64f3a0389e..000000000000
--- a/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naur fsviewer-app-0.2.6.orig/configure.ac fsviewer-app-0.2.6/configure.ac
---- fsviewer-app-0.2.6.orig/configure.ac 2012-07-11 17:55:06.448981246 +0200
-+++ fsviewer-app-0.2.6/configure.ac 2012-07-11 18:04:15.528940159 +0200
-@@ -81,6 +81,8 @@
- AC_MSG_ERROR([WMaker library not found]))
- AC_CHECK_LIB(WINGs, WMAppSetMainMenu,,
- AC_MSG_ERROR([WINGs library not found]))
-+AC_CHECK_LIB(WUtil, WMCreatePLString,,
-+ AC_MSG_ERROR([WUtil library not found]))
-
- dnl Checks for PropList (not necessary since version 0.2.3b)
- dnl AC_CHECK_HEADERS(proplist.h,, AC_MSG_WARN(Can't find PropList include-file: Please install libPropList (included in WindowMaker)))
-diff -Naur fsviewer-app-0.2.6.orig/defs/chdef.c fsviewer-app-0.2.6/defs/chdef.c
---- fsviewer-app-0.2.6.orig/defs/chdef.c 2012-07-11 17:55:06.444981361 +0200
-+++ fsviewer-app-0.2.6/defs/chdef.c 2012-07-11 17:55:50.387699640 +0200
-@@ -374,7 +374,7 @@
- SetIntegerForKey(0, "DisplayMCListPixmap");
-
- WMWritePropListToFile(filesDB,
-- wdefaultspathfordomain("FSViewer"), True);
-+ wdefaultspathfordomain("FSViewer"));
- result = 0;
- }
- else
-diff -Naur fsviewer-app-0.2.6.orig/src/extnInspector.c fsviewer-app-0.2.6/src/extnInspector.c
---- fsviewer-app-0.2.6.orig/src/extnInspector.c 2012-07-11 17:55:06.452981130 +0200
-+++ fsviewer-app-0.2.6/src/extnInspector.c 2012-07-11 17:56:02.315351669 +0200
-@@ -229,7 +229,7 @@
-
- if(numRows > 0)
- WMWritePropListToFile(filesDB,
-- wdefaultspathfordomain("FSViewer"), True);
-+ wdefaultspathfordomain("FSViewer"));
-
- if(extn)
- free(extn);