summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin47367 -> 47379 bytes
-rw-r--r--x11-misc/autorandr/Manifest3
-rw-r--r--x11-misc/autorandr/autorandr-1.12.1-r1.ebuild65
-rw-r--r--x11-misc/autorandr/autorandr-9999.ebuild4
-rw-r--r--x11-misc/gccmakedep/Manifest2
-rw-r--r--x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild4
-rw-r--r--x11-misc/redshift/Manifest2
-rw-r--r--x11-misc/redshift/redshift-1.12-r7.ebuild85
8 files changed, 159 insertions, 6 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index 661d07034f1d..38eb3d86216d 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/autorandr/Manifest b/x11-misc/autorandr/Manifest
index 82422064085d..3f44fc9dcee4 100644
--- a/x11-misc/autorandr/Manifest
+++ b/x11-misc/autorandr/Manifest
@@ -1,4 +1,5 @@
DIST autorandr-1.12.1.tar.gz 45550 BLAKE2B 5b434325d13c00c3fa70b5d09edb540cdcf3bb921307c60f2c616231e7a87ea85f60e39500ed8116f28619139f71ecc4a8fa153ffadc6b8d74df570736a0d815 SHA512 a7e095eb96e7e0d3a5b3b2122d68a3d3a5121d8be7a86ddd9f837ad42b7a53ed5ee45151f23861c5b900e214a4dfc0c575f45fe70c8c5587562a4035458137a0
+EBUILD autorandr-1.12.1-r1.ebuild 1334 BLAKE2B 989f72dd2b1a728bf59c0d6cfc273efe81e1b4fd4bb53136f500d087b5f6d035fbe5f5d714b426cfa7aecba1c18e2e3bf49dabb213a8bdc22ef14e3858fb9338 SHA512 cb4b2dcdd702612e04822fd9eafff8863f4563dbf965c83a3c393f5793020a53e63031627e6dc889ca49712c07d901d8da88840edf548d4d3b580bd5bcd66936
EBUILD autorandr-1.12.1.ebuild 1316 BLAKE2B 5c13c316e1a1878f7507178c15dea312af45867841bc70baa26f0ea5aab8f9e98a99e9953a85aacff68a075abacf914c9e8009726cc4890a733086ada9c2a74f SHA512 5b6f8d86a28c19763d690abfc65787e3a1b7fac32be2a5689e29fd2ef92928865771e12163f242e25be9297eaaba238d7fa6d13420ca645933a9ed0eb7905a83
-EBUILD autorandr-9999.ebuild 1318 BLAKE2B 5892e8c61fe2ff231f20937d9bd31004eb2710043fc48a077214b07d7f68716409b7049113ecbd6a444f6b694d40265179f87312fc2e7e60afd90aa7753c02a2 SHA512 d4339f7ee1675fb0a539cbae61126c7f4fcb40014abacf08db1d58b37992a2250709fe041f6a620758bfb0abee6ea95b95321dc2de96840ff8546080051a586e
+EBUILD autorandr-9999.ebuild 1334 BLAKE2B 989f72dd2b1a728bf59c0d6cfc273efe81e1b4fd4bb53136f500d087b5f6d035fbe5f5d714b426cfa7aecba1c18e2e3bf49dabb213a8bdc22ef14e3858fb9338 SHA512 cb4b2dcdd702612e04822fd9eafff8863f4563dbf965c83a3c393f5793020a53e63031627e6dc889ca49712c07d901d8da88840edf548d4d3b580bd5bcd66936
MISC metadata.xml 355 BLAKE2B 51f7f0670462cbded6b65379488447fca9862fd75ecc262e3a627c268d184abae82feb8a3835486d2c39d18ad0882db6f1f6c9ff9df4fac19457b4ec3a1f6621 SHA512 a9e16f58beeda5d64b48240ef23dfe4349d8c962e08df19cd3fa60846891719fceba2f69b3affba64b8d6f8c2ec96b1dc544a4ada52efd53e6d15b1aa1734677
diff --git a/x11-misc/autorandr/autorandr-1.12.1-r1.ebuild b/x11-misc/autorandr/autorandr-1.12.1-r1.ebuild
new file mode 100644
index 000000000000..0badb8f708aa
--- /dev/null
+++ b/x11-misc/autorandr/autorandr-1.12.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit bash-completion-r1 distutils-r1 systemd udev
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
+else
+ SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Automatically select a display configuration based on connected devices"
+HOMEPAGE="https://github.com/phillipberndt/autorandr"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="launcher systemd udev"
+
+RDEPEND="
+ x11-apps/xrandr
+ launcher? ( x11-libs/libxcb )
+ udev? ( virtual/udev )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use launcher; then
+ emake contrib/autorandr_launcher/autorandr-launcher
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman autorandr.1
+
+ local targets=(
+ autostart_config
+ bash_completion
+ $(usev launcher)
+ $(usev systemd)
+ $(usev udev)
+ )
+
+ emake DESTDIR="${D}" \
+ BASH_COMPLETIONS_DIR="$(get_bashcompdir)" \
+ SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ $(printf "install_%s " "${targets[@]}")
+}
+
+pkg_postinst() {
+ if use udev; then
+ udev_reload
+ fi
+}
diff --git a/x11-misc/autorandr/autorandr-9999.ebuild b/x11-misc/autorandr/autorandr-9999.ebuild
index 4433c9b58d70..0badb8f708aa 100644
--- a/x11-misc/autorandr/autorandr-9999.ebuild
+++ b/x11-misc/autorandr/autorandr-9999.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="https://github.com/phillipberndt/autorandr"
LICENSE="GPL-3"
SLOT="0"
-IUSE="launcher udev"
+IUSE="launcher systemd udev"
RDEPEND="
x11-apps/xrandr
@@ -46,8 +46,8 @@ src_install() {
local targets=(
autostart_config
bash_completion
- systemd
$(usev launcher)
+ $(usev systemd)
$(usev udev)
)
diff --git a/x11-misc/gccmakedep/Manifest b/x11-misc/gccmakedep/Manifest
index c827a08814ac..58e705dbf6d7 100644
--- a/x11-misc/gccmakedep/Manifest
+++ b/x11-misc/gccmakedep/Manifest
@@ -1,4 +1,4 @@
DIST gccmakedep-1.0.3.tar.bz2 104766 BLAKE2B 4da8c3d4423f55fa110b1be748e9488b713a36b575f065f58d68c24eb4fdfc337aa9c715b82dfaac6eaaf8cb2037ab4d0355297a61c39f7e7672f136bb1395d8 SHA512 563b2897770a4df2792ea3eae8183a1f9e78192b7efc9c8296ee68d1cba6e72fa962a88e3251bb780df776e2aa7e80d74d5096675c61526c232aefa4f9e6a5fc
-EBUILD gccmakedep-1.0.3-r1.ebuild 968 BLAKE2B 04b4dc94835b6efa6335cc10b9eb41cdbe5477208b102626c6eab4b5ea78a25029eefc78e0d56480d172ea8290d501848fface0db6175a3ff4301b28f681f975 SHA512 eaf38671b5f6cc997dd17c1e8471928fb3c77cfa25ae2ada7ad7bd83ade36a52ac4bc80aa6acb93647522baa347ba0620656617a348ba0e87ddcfbfd3325190b
+EBUILD gccmakedep-1.0.3-r1.ebuild 975 BLAKE2B 8d3e791a5d2ba9f81f10714577caa823a65dfda5a7d75a07f7d499aa3f0428bf9f661490534e29c628fe1d0dd64513f12058ce0bef4fb46a278088b9f2f47526 SHA512 8d3991c413f9d2640200c371b13c4a65ae01bd44cebe2adb2e70102b06e470a84f48e0e1f89c2f3e2deaad393adc497ff51a484337823d08250d4091f4820b55
EBUILD gccmakedep-9999.ebuild 975 BLAKE2B 6be79c4fe954b518982837821e7737ff17183ad9825eeb201374a4df33655cb06bc588ae0c849f1a457ae24ac0aa4219c16212557ca6c19e3d511131c644beb7 SHA512 2ea4c1331c8067a60d60be36e7c6cac62bc3fef147affd48c4c42f65732e3516e3b2a9dea212dbce3d5a5d0f47a192fe6bdac97693bd17326f1c445efb99c566
MISC metadata.xml 342 BLAKE2B 8a918dbed8adc0ca2dd4fb47840a2a13199f26ea3cacc46391974a9b797006bd710f5d4fcbc265361f3e23cb5cb8f7f9358d27549f7ff21ef0381a11f5fe2346 SHA512 ccb760eec62a031973b2e5d9a553833430d7dd51b71a91943b30ff58352a9838fa303e146150cb9e460e0121c61c3d293a1588fac5b5c610aabb5e3f091a18c5
diff --git a/x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild b/x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild
index 8207bd2715a2..9db630f28c56 100644
--- a/x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild
+++ b/x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
LIVE_DEPEND=">=x11-misc/util-macros-1.18"
else
SRC_URI="https://www.x.org/releases/individual/util/${P}.tar.bz2"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="MIT"
diff --git a/x11-misc/redshift/Manifest b/x11-misc/redshift/Manifest
index 9942e8cb50eb..04c6b4a6e708 100644
--- a/x11-misc/redshift/Manifest
+++ b/x11-misc/redshift/Manifest
@@ -1,3 +1,5 @@
DIST redshift-1.12.tar.gz 659019 BLAKE2B 09339a57fee192e3428ba4387cbea498f2f9f97eb75a418588cdda3289cfa7b7fada4cb299e983e9e6d2ffe3822c8235082e67bdfa542716b6dee9fc853a8dc1 SHA512 6763f6964b577fc146191af1c67a283a60df5bbdd3a74bfc94f66d5f9f3bef8835a479c6ec8a648b650b83a0e245928884a0f628606ace8c3f58d8319d35036f
+DIST redshift-1.12.tar.xz 486072 BLAKE2B b7ce74ae134a8f6954ff978e99670f24c447b23ab5e8d69a62109806bfe38c5e1b41e5f65cd6b182298aaf3e0b9187a2c70ea3148fd4ccba8b9c17697024944d SHA512 225e222e5f2c55be4571094ccaf02a92e162dfc35fd0fe504084e21e358b888a72f9992f9f9edaf1d496eb673af74a0d825ae5cf6ef7f0f1ab51d32419722c32
EBUILD redshift-1.12-r6.ebuild 2068 BLAKE2B b41852d9f1f2c7ecf9aefefb639a6015f59359cda19a8de920cce72def7df0d2911c81acd48978b5ae48108aad4e08af203a5cc912c39bbc3cb471855d5d7872 SHA512 6018aa1673c9cb12c0e99892b0f1f1c04eb12b22172ac83d187620f6fe8dcc558f42d3292a35bccbe799ab1669d27b0a9b3cd394e8b7942d27f5a6932e7882bc
+EBUILD redshift-1.12-r7.ebuild 2017 BLAKE2B 8f02639d4f575e2ef19df39859bec90d3ac4938cd704dd7b08bd4afe7c5599295ea5002bd39762b24c92dfad15bfde703bcf0c7554862704fb1bbdf0f412faa2 SHA512 2153568f472b8264ebab11c042386d270d812808f4e54df6f048c5fb29e33338ad7dfb2e706bf049bc7ace718a89bbb9844714c88de454ba4b1a2ac3d88ee416
MISC metadata.xml 522 BLAKE2B db9be8da0b96a5f7d742baadda739df011a5f055a944d41b67b3ba3137b7e92acead9b0afd72410a4c4f203fedf300f49a052c809577351b3b107f447dbf4c6b SHA512 c5732a20ce965daea3c663ba00d2fd9ea484cade35c22011a9e4f051ce202a0da560c428c8775b5eefaa726c92f6f31014cc47780b4ba329db81c1dd7defbbbc
diff --git a/x11-misc/redshift/redshift-1.12-r7.ebuild b/x11-misc/redshift/redshift-1.12-r7.ebuild
new file mode 100644
index 000000000000..3fd13868f5ba
--- /dev/null
+++ b/x11-misc/redshift/redshift-1.12-r7.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit flag-o-matic systemd xdg-utils python-r1
+
+DESCRIPTION="A screen color temperature adjusting software"
+HOMEPAGE="http://jonls.dk/redshift/"
+SRC_URI="https://github.com/jonls/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="appindicator geoclue gtk nls"
+
+COMMON_DEPEND=">=x11-libs/libX11-1.4
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ x11-libs/libdrm
+ appindicator? ( dev-libs/libappindicator:3[introspection] )
+ geoclue? ( app-misc/geoclue:2.0 dev-libs/glib:2 )
+ gtk? ( ${PYTHON_DEPS} )"
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( dev-python/pygobject[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ dev-python/pyxdg[${PYTHON_USEDEP}] )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ nls? ( sys-devel/gettext )
+"
+REQUIRED_USE="gtk? ( ${PYTHON_REQUIRED_USE} )"
+
+src_configure() {
+ use gtk && python_setup
+
+ # Fix compile for Clang (bug #732438)
+ append-cflags -fPIE
+
+ econf \
+ $(use_enable nls) \
+ --enable-drm \
+ --enable-randr \
+ --enable-vidmode \
+ --disable-wingdi \
+ \
+ --disable-corelocation \
+ $(use_enable geoclue geoclue2) \
+ \
+ $(use_enable gtk gui) \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)" \
+ --enable-apparmor \
+ --disable-quartz \
+ --disable-ubuntu
+}
+
+_impl_specific_src_install() {
+ emake DESTDIR="${D}" pythondir="$(python_get_sitedir)" \
+ -C src/redshift-gtk install
+}
+
+src_install() {
+ emake DESTDIR="${D}" UPDATE_ICON_CACHE=/bin/true install
+
+ if use gtk; then
+ python_foreach_impl _impl_specific_src_install
+ python_replicate_script "${D}"/usr/bin/redshift-gtk
+ dosym redshift-gtk /usr/bin/gtk-redshift
+
+ python_foreach_impl python_optimize
+
+ # https://bugs.gentoo.org/784281
+ mv "${D}"/usr/share/{appdata,metainfo}/ || die
+ fi
+}
+
+pkg_postinst() {
+ use gtk && xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && xdg_icon_cache_update
+}