summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin47237 -> 47243 bytes
-rw-r--r--x11-misc/autorandr/Manifest4
-rw-r--r--x11-misc/autorandr/autorandr-1.13.1.ebuild72
-rw-r--r--x11-misc/autorandr/autorandr-9999.ebuild2
4 files changed, 76 insertions, 2 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index ac26f6e8182c..a4bb35dd6fe5 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/autorandr/Manifest b/x11-misc/autorandr/Manifest
index 9cb82bb9f88e..ab58b7b271af 100644
--- a/x11-misc/autorandr/Manifest
+++ b/x11-misc/autorandr/Manifest
@@ -1,5 +1,7 @@
AUX autorandr-Makefile-fix-install_udev-target-by-s-TARGETS-MAKECM.patch 1682 BLAKE2B 6c168ffc8e0b217999e4780a9776c6ca7d1fd16868a00ec8301ab8b94412033a38cec28929bb21d7a39fe18544244a947891715a32fe1e80d927b3550dec8513 SHA512 8d3b1164e962bd6b6d741e22f1328b98037b6f2ea878ffe26da07f22947476ca35c5fa066462b913fda7319b8671055c3f28354261daf6e5c3301d7a85f5dc88
DIST autorandr-1.12.1.tar.gz 45550 BLAKE2B 5b434325d13c00c3fa70b5d09edb540cdcf3bb921307c60f2c616231e7a87ea85f60e39500ed8116f28619139f71ecc4a8fa153ffadc6b8d74df570736a0d815 SHA512 a7e095eb96e7e0d3a5b3b2122d68a3d3a5121d8be7a86ddd9f837ad42b7a53ed5ee45151f23861c5b900e214a4dfc0c575f45fe70c8c5587562a4035458137a0
+DIST autorandr-1.13.1.tar.gz 47380 BLAKE2B f3173d795294eaa89d4f8c98d8bf6dc6a9c09d57649c228d17759e76d9c15d66b32803a63a07f44090b8d4580af8ae9dd42a3c8ff76d91f47d82f58896aebea6 SHA512 b090de5b4c7ff3d886d6aabac695a694983704678eedb31b4cbfdc88e6569e1f1c4e32ed5d16e59d0c98702c93c8600e7625d4d88dd6c988c7db131364cfb6f7
EBUILD autorandr-1.12.1-r2.ebuild 1571 BLAKE2B cc9ee1819681f13aa237e4ffac593834822f795cb9d5c41b94edd39262ed345cb5772efbc35f177afe9a5ef1379b5cdd6bffdc52fd97b210f75db5c5ef32dd38 SHA512 ae624c9ed4df52dfdb9061c147f6339ff9c4c50234650315feee79765973273bd6c34b0de7db843c6deb1b9ff36d690ecefd854e512d82e553da40b49c394cbc
-EBUILD autorandr-9999.ebuild 1421 BLAKE2B 24c2aa2fa69a90b1fc516d4de468ed86515db4a6131f482b29aa7eedc6d8b86741943a6d8cebb8252c777d41a2072d41fbde2c5d786ed11280c4fbd8116d35d5 SHA512 088721f3ed12086c910aa163854c963f80dec526f7d8dfef0f48b9e4acf85c2efe7e9b82a2addf74d1541d524f0011584aa2ff783f211c4841c84b80e67e4fbd
+EBUILD autorandr-1.13.1.ebuild 1421 BLAKE2B d4b6c1e08c1f17aa039473c27e7c88f63507824f4c0e255a6bc823cfa0e789c56ec3f615ec35c3eb2a35bed6b0c12c6b843906a5f6164f05cf763123b83b9554 SHA512 738285e95ba6437a76cbbd8685edd3ad83e5c174040bff154bd0fb4248ed24aac5a84caa0832215fc7bc7e250f2ba2d2e437a506495d48c505ef9e858637bc15
+EBUILD autorandr-9999.ebuild 1421 BLAKE2B d4b6c1e08c1f17aa039473c27e7c88f63507824f4c0e255a6bc823cfa0e789c56ec3f615ec35c3eb2a35bed6b0c12c6b843906a5f6164f05cf763123b83b9554 SHA512 738285e95ba6437a76cbbd8685edd3ad83e5c174040bff154bd0fb4248ed24aac5a84caa0832215fc7bc7e250f2ba2d2e437a506495d48c505ef9e858637bc15
MISC metadata.xml 450 BLAKE2B bb36360893882faa3306ce69953a4c699e613dd5608bd379c3a179cd68d79ce42171c01611fb08269b9521eca61c67825ea1d52711a0ac67fa99f919350b54bd SHA512 d676779669537dff4c0964d48996b3cdcbc1b6d7f3f00412b48614f42b86b6acdea05b646d3d9d048db6b19e0733bbc1281ed8dbea7d4ea36f19f14c5a055d29
diff --git a/x11-misc/autorandr/autorandr-1.13.1.ebuild b/x11-misc/autorandr/autorandr-1.13.1.ebuild
new file mode 100644
index 000000000000..c4b2f818767a
--- /dev/null
+++ b/x11-misc/autorandr/autorandr-1.13.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit bash-completion-r1 distutils-r1 systemd udev
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
+else
+ SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Automatically select a display configuration based on connected devices"
+HOMEPAGE="https://github.com/phillipberndt/autorandr"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="launcher systemd udev"
+
+RDEPEND="
+ x11-apps/xrandr
+ launcher? ( x11-libs/libxcb )
+ udev? ( virtual/udev )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use launcher; then
+ emake contrib/autorandr_launcher/autorandr-launcher
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman autorandr.1
+
+ local targets=(
+ autostart_config
+ bash_completion
+ $(usev launcher)
+ $(usev systemd)
+ $(usev udev)
+ )
+
+ emake DESTDIR="${D}" \
+ BASH_COMPLETIONS_DIR="$(get_bashcompdir)" \
+ SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ $(printf "install_%s " "${targets[@]}")
+}
+
+pkg_postinst() {
+ if use udev; then
+ udev_reload
+ fi
+}
+
+pkg_postrm() {
+ if use udev; then
+ udev_reload
+ fi
+}
diff --git a/x11-misc/autorandr/autorandr-9999.ebuild b/x11-misc/autorandr/autorandr-9999.ebuild
index f1195c0bd95d..c4b2f818767a 100644
--- a/x11-misc/autorandr/autorandr-9999.ebuild
+++ b/x11-misc/autorandr/autorandr-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )