summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin47039 -> 47043 bytes
-rw-r--r--x11-misc/mozo/Manifest2
-rw-r--r--x11-misc/mozo/mozo-1.26.2.ebuild64
-rw-r--r--x11-misc/revelation/Manifest2
-rw-r--r--x11-misc/revelation/revelation-0.5.5.ebuild2
-rw-r--r--x11-misc/rofi-calc/Manifest6
-rw-r--r--x11-misc/rofi-calc/rofi-calc-2.0.0.ebuild7
-rw-r--r--x11-misc/rofi-calc/rofi-calc-2.2.0.ebuild31
-rw-r--r--x11-misc/rofi-calc/rofi-calc-9999.ebuild9
9 files changed, 116 insertions, 7 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index dcd8c07ca6d0..15a898c1bdfc 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/mozo/Manifest b/x11-misc/mozo/Manifest
index 624d0eb25cac..4521c2a5ee9b 100644
--- a/x11-misc/mozo/Manifest
+++ b/x11-misc/mozo/Manifest
@@ -1,3 +1,5 @@
DIST mozo-1.26.1.tar.xz 242836 BLAKE2B 59047b087e531792c0e831779d06a2dc7d9d2709bef7a7c8ba4a21d6f9fe1a79f917e2ba4e4912d655ad94391c0f7789e6ad6394be1a7bcb482881781f81c9ff SHA512 8570db4719d88bb34269a23acaa63638c5b7e50bf840bca73db718040c9d585670f1fd3be128c51ff22b4314f59dad6050907db8ce60bb506e4d46c3f807707e
+DIST mozo-1.26.2.tar.xz 249672 BLAKE2B 95e9a04fc91424e8ce95e870253bf1d2eddfbbf1b78b632b15d057a3ffa86068bb2c89442cfc50c4f74a76e75b345c6b06cf47d5891eed3ffce460697fb0094b SHA512 c4ea00f97f4dd5c9b33b78e1b438ba80a5e23b69d05f6ea59c522a580c1b07c280cddc0591f266c16f39bbe5f3e07ca28cdbd33753162a02584b551a9857b904
EBUILD mozo-1.26.1.ebuild 1284 BLAKE2B 4acc6d08a9ce787d6363b44e21d271ff57ee88386ae509b3f74fd7e1d4c533f4839e5010c897151b1bc19c2e4d030407efa0624127668f12ce415fc777d908bd SHA512 62e2a3c2fe6514e145d0068c26731ec829e19faf4590af2e20ceb8ecbb62733ecd6988a52f88d4c719983c225a713456fecf1765ad2e5b84781bc19f888cd3b3
+EBUILD mozo-1.26.2.ebuild 1258 BLAKE2B 0aa0fa4820c3984dad7abc7dbb3ba7fb7d725ad40952d13169d524a7153d19e1cc75f91438158e4c60ca1dae51101a90ccb808e44dc33b46f3fd3818ed8f2bce SHA512 c290edf6a86786698a0838f79894a7d0a79358ddd071fa8049a022dde3931c386e1df3ab88b059caae18eb21aa6e0d33e7a2c3ae28270c04f11e1722a4d23774
MISC metadata.xml 334 BLAKE2B 2d3b282a39f97386fb0986f460903c132a59464c1f408bcf1e081198aa07ff38cdd50fe460d2bb20a2dd17ccd6a6d7e49b31d5615b892591466a019001bd5727 SHA512 d04ccb64388d150947f281085fe3c70e5285d56518eb6359bb81d533fbaf2a44aee23e2d3f04896bbe15df07a5260a688949ed8505b9c87a857fc0882a425d74
diff --git a/x11-misc/mozo/mozo-1.26.2.ebuild b/x11-misc/mozo/mozo-1.26.2.ebuild
new file mode 100644
index 000000000000..29f2da4774bc
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.26.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit mate python-r1
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2+ GPL-3+ LGPL-2+ LGPL-2.1+"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.21.0[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.12:3[introspection]
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ python_optimize
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/x11-misc/revelation/Manifest b/x11-misc/revelation/Manifest
index 0d29a4da1751..c4c896138f6d 100644
--- a/x11-misc/revelation/Manifest
+++ b/x11-misc/revelation/Manifest
@@ -1,3 +1,3 @@
DIST revelation-0.5.5.tar.xz 282252 BLAKE2B 7c4c430d24d79b820139dd2b4989dc2d78c967b16c864149d2aafa9e91ddc26a3351f42b5782812202f77a36529c46d9515cc1aea73346c7e8e017079b810a7d SHA512 17bfeda87e27c00f12bc068446d053cee394282e5eabea6d075ac262b5f400f31520d2f9b29f99097d1d6ad72bbcf5d2d9d4da2a0eba2806ff0adbf1bb47bb0f
-EBUILD revelation-0.5.5.ebuild 1206 BLAKE2B 13d4170feec99b927bb878957d0f26ba2b1ccd8aac85bc3a0ddd5b53389858d51840bd0471b8f91b8aeb925e8577c7bc059c87afb731fb00357071a025d0f366 SHA512 081b783c95b2154f2010d06c1a2a55e2e502e4f03ebf73432c43e5f426392c0445bd009617b7d42c396e333f74d223d0f39ab052d47fceb7d523c5dcf9a08193
+EBUILD revelation-0.5.5.ebuild 1207 BLAKE2B b17d4b5edb9aa7218b9e77638153868a652444e9b0d92a81e1db879273da687d566e36e20800102f6f44c312f0e050cf73ae764b0368dec2220c1f863ff23551 SHA512 1d788b1aa7696797565376906ee6118cb5ceb611e79f50ed0b55746414267c4faabb83fd62e5a64baeea9933e15140f342ffdc73c47bf6686c6014e07fe1d5c0
MISC metadata.xml 508 BLAKE2B 56bfae4b0e27795147d666c1c3c52721a71c817dc637e6e6c5f301c298c523576ef040aa216b4156e9fe609cfed3b8756c18fa9d7515b639079e08531ff2e6f6 SHA512 307713b87335c7778f68484c143f842037380c4c55fa200e5630582544d1fdfddf00efb378ed286bc70d94918d6f1643508483779791bde7de499f9121e6a823
diff --git a/x11-misc/revelation/revelation-0.5.5.ebuild b/x11-misc/revelation/revelation-0.5.5.ebuild
index 31deaaf42451..f31aeae6bc97 100644
--- a/x11-misc/revelation/revelation-0.5.5.ebuild
+++ b/x11-misc/revelation/revelation-0.5.5.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit gnome2-utils python-single-r1 meson xdg
diff --git a/x11-misc/rofi-calc/Manifest b/x11-misc/rofi-calc/Manifest
index fcb5d574ce5b..564ef65cb8e7 100644
--- a/x11-misc/rofi-calc/Manifest
+++ b/x11-misc/rofi-calc/Manifest
@@ -1,4 +1,6 @@
DIST rofi-calc-2.0.0.tar.gz 1695125 BLAKE2B d76c304724b0f3326a8bd26ab2c7eaed5f77f3b6d07ddc97570a1fb28d56504d98ac9ab66411290cb548b760bd3231a729dfc470e748a8447e323d1b290f677c SHA512 298f9983dbd140f5aee5b3799b165500eae100f3f5744ba07914b962faf01661dee0f5f4c9c12a07a4e210b6115ac6fb377d9fa9a7e64ef5a19600e9f55cd478
-EBUILD rofi-calc-2.0.0.ebuild 487 BLAKE2B 7e5ebe0a0f34d2fd09d0d6bf5181de919961f24c1dd38ad40e3c80cd249518b097448d2dc1c0cd8177d2d8323595f4e52788b010f93800cd6c10ca269b2aa8b0 SHA512 0abfc58d30bbbe41472a45cac711d0edfb6a9bfe94c7678b0929e79d5ff0fddc0fef320f7369f43a31647b68f9aaaa48d1b68d7839dd665bab84a9e0efe97bf9
-EBUILD rofi-calc-9999.ebuild 467 BLAKE2B fc14f1346f9e5ee3a4199d3f346b0be73ba077311efa515abfef36cecaa6e4299949a6027a0de6190c8ecde529904abb76b2ba2afcf3a605a6433170f66faa34 SHA512 96a703783182f67fb241919b540a5ef2f961a2eed5db80118679bb47eac2c508b695fa1ec389ceaf964860ee9758f878546bf4303e667f9b03757d2289acf2a8
+DIST rofi-calc-2.2.0.tar.gz 1695821 BLAKE2B ab91e17c2baa854e76f593626b774390b5bdd57c78419c16981371f1e4be64cee0a38845dcd93998741ceeac462a1158af08519692c65a04a22418aa7026dc89 SHA512 7eedb5c7be97f42a1683cabdf0745c28d2a4f123f02e7cf2bf5a44cf851271b5bdc31f7622f4f30d086ecdcbcc7e4d62d3550b8c5b8ceebcdaca362e8d09a68d
+EBUILD rofi-calc-2.0.0.ebuild 557 BLAKE2B ae68586334b9114f2a89dd45fe9b5a5dccc2c572537a6a36f5f108aaede9a16d8be87c936818a85dcb9a61199f81cd9e4aa503196c4017eb65d1c158de8c6947 SHA512 7080c170c773f02b8a1c0cd1db20248b5811c0be503147e408b13d838a07e3963ff9b388dd4f927a043ce2162ce7246f30be95caa29a3b3ddad693ae88d0cd7f
+EBUILD rofi-calc-2.2.0.ebuild 557 BLAKE2B 26b07f9207d77f7ff01a2cde318d62e5d8e63175af5009eb081e9cc9724c3ac072b9bcf96d7ce5949cadfac4c1cf030c95f3a5e06637f94763fcdc88f9c18218 SHA512 944bbca58befa5a6cf23912e018a2986097f3f67da6efa4396eed32fd7068c60e89e7ced1e925343ef1524678585c5f98a05a0361dd42c116daa7aecfce1757e
+EBUILD rofi-calc-9999.ebuild 537 BLAKE2B 3de16f76ff930224550bb2d1aed2eb3c1181338219ba5c9f600e69bcded74c6945e9f40db1cd14eae2be1c6931e15677f9380cf1b1d6a37ff4dd22427e6b19ba SHA512 dca03c972c70d2b5904d6d149f713332f9b3287571874af87865918cd85f382387d90777969c995ab4deff877a706e0268887dba884a41aba1d8e1004838705f
MISC metadata.xml 267 BLAKE2B 7dd5bd0b69e7b01ffc3a7d2088a9e815eb7cd1a29779b67c76236d1cfeb3d4a6d107747af1ce010df73f21de3b2a60ac50bee767900b67e9deb0e4076891c9b5 SHA512 0c9213901130dda93d68de656cf5a9a771511307db4ebd351b6b5b56c969d7a3aee08393882a267fd06b9ee4fa16f9aa5996d117a7f9df3c7ec15983bc95a494
diff --git a/x11-misc/rofi-calc/rofi-calc-2.0.0.ebuild b/x11-misc/rofi-calc/rofi-calc-2.0.0.ebuild
index a267871cd50b..ce53ee1c9e75 100644
--- a/x11-misc/rofi-calc/rofi-calc-2.0.0.ebuild
+++ b/x11-misc/rofi-calc/rofi-calc-2.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,3 +24,8 @@ src_prepare() {
default
eautoreconf -i
}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/x11-misc/rofi-calc/rofi-calc-2.2.0.ebuild b/x11-misc/rofi-calc/rofi-calc-2.2.0.ebuild
new file mode 100644
index 000000000000..5264d2023257
--- /dev/null
+++ b/x11-misc/rofi-calc/rofi-calc-2.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Do live calculations in rofi!"
+HOMEPAGE="https://github.com/svenstaro/rofi-calc"
+SRC_URI="https://github.com/svenstaro/rofi-calc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ x11-misc/rofi
+ >=sci-libs/libqalculate-2.0
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf -i
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/x11-misc/rofi-calc/rofi-calc-9999.ebuild b/x11-misc/rofi-calc/rofi-calc-9999.ebuild
index c70193f7e119..ac69969f2903 100644
--- a/x11-misc/rofi-calc/rofi-calc-9999.ebuild
+++ b/x11-misc/rofi-calc/rofi-calc-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit git-r3 autotools
@@ -25,3 +25,8 @@ src_prepare() {
default
eautoreconf -i
}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}