summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin48599 -> 48598 bytes
-rw-r--r--x11-misc/notify-osd/Manifest2
-rw-r--r--x11-misc/notify-osd/notify-osd-0.9.34-r1.ebuild (renamed from x11-misc/notify-osd/notify-osd-0.9.34.ebuild)31
-rw-r--r--x11-misc/redshift/Manifest2
-rw-r--r--x11-misc/redshift/redshift-1.11-r1.ebuild4
-rw-r--r--x11-misc/xdotool/Manifest2
-rw-r--r--x11-misc/xdotool/xdotool-3.20160805.1.ebuild2
7 files changed, 25 insertions, 18 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index 3dbe2f7decd1..4b095f6cbe4a 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/notify-osd/Manifest b/x11-misc/notify-osd/Manifest
index 4e0e19cb5231..e6645843682d 100644
--- a/x11-misc/notify-osd/Manifest
+++ b/x11-misc/notify-osd/Manifest
@@ -1,3 +1,3 @@
DIST notify-osd-0.9.34.tar.gz 635387 BLAKE2B 469369f9fde562c605c131608b56eb54ea2a5f3d16f530e5b383d04fd8de2fbd531b58ed43caceeaeef65840cb00917484c02f8af0d7a0fc464ab131c1193853 SHA512 60ca63c2041f129d5139537242c2260908cedef633df977a608e19dcb01b75b2280ec80abe2b6da5eff76621107ee9d294742abfae301bc24eaa3aa855c56ce1
-EBUILD notify-osd-0.9.34.ebuild 1439 BLAKE2B 7f7e41d74b1a9c467144d903ed713b6219df2bebf4c1d17070cf6ecdbacfb6f9364af56240c153be216f1f95d42e9a4ce69b2645e8f0dc68b3b3579b8102dcb1 SHA512 36760f312cc4d47a0489850c9066b19f823fe5884effc3b629c0634fa4c1874bee65f6e4c5273b9133d3369292d611186db60387edea776b1eb812877e28f0a2
+EBUILD notify-osd-0.9.34-r1.ebuild 1482 BLAKE2B 9ddb836069999b6f5fa0319a31ed63e79f036b23f48eef1a91a26dcb446d1a3d278a729cf691e37343c06d41a346f1d66686c9f3e6716eb335635e5c09425e04 SHA512 81a7ace69f169b2ef2b3e68be5403a9058db3cba5ce0b47de3902bfcccb8571a6f231539060057f39f28966509ab5e27cc52f0da3e028974f917851f10136edb
MISC metadata.xml 250 BLAKE2B 138c4f4c717e9e24abf19f3d4cb9a8a8b49761ac301ac26b527c86802bbc509a4afd2678adb71bc3a9ef3d0ea17438d57d03211627bcf6ace221f08f39151f56 SHA512 0bed48908552a27396c77549264bbb7516677909afdecd967cce446529ea944c8f9ddf167241a033ca790123be27f8e3a4c503954100f9ea076f40b8ef5b0209
diff --git a/x11-misc/notify-osd/notify-osd-0.9.34.ebuild b/x11-misc/notify-osd/notify-osd-0.9.34-r1.ebuild
index 70ae583ebe58..95bd82cc0720 100644
--- a/x11-misc/notify-osd/notify-osd-0.9.34.ebuild
+++ b/x11-misc/notify-osd/notify-osd-0.9.34-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools gnome2-utils multilib savedconfig
+EAPI=6
+inherit autotools gnome2-utils savedconfig
DESCRIPTION="Canonical's on-screen-display notification agent"
HOMEPAGE="https://launchpad.net/notify-osd"
@@ -13,34 +13,39 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="minimal"
-COMMON_DEPEND=">=dev-libs/dbus-glib-0.98
- >=dev-libs/glib-2.16
+COMMON_DEPEND="
+ >=dev-libs/dbus-glib-0.98
+ >=dev-libs/glib-2.16:2
>=x11-libs/gtk+-3.2:3
>=x11-libs/libnotify-0.7
- >=x11-libs/libwnck-3
+ >=x11-libs/libwnck-3:3
x11-libs/libX11
x11-libs/pixman
!x11-misc/notification-daemon
- !x11-misc/qtnotifydaemon"
+ !x11-misc/qtnotifydaemon
+"
RDEPEND="${COMMON_DEPEND}
- !minimal? ( x11-themes/notify-osd-icons )"
+ gnome-base/gsettings-desktop-schemas
+ !minimal? ( x11-themes/notify-osd-icons )
+"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
gnome-base/gnome-common
- x11-proto/xproto"
+ x11-proto/xproto
+"
RESTRICT="test" # virtualx.eclass: 1 of 1: FAIL: test-modules
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
-
src_prepare() {
+ default
sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
restore_config src/{bubble,defaults,dnd}.c #428134
+ mv configure.in configure.ac || die
eautoreconf
}
src_configure() {
- econf --libexecdir=/usr/$(get_libdir)/${PN}
+ econf --libexecdir="/usr/$(get_libdir)/${PN}"
}
src_install() {
@@ -53,10 +58,12 @@ pkg_preinst() {
gnome2_icon_savelist
gnome2_schemas_savelist
}
+
pkg_postinst() {
gnome2_icon_cache_update
gnome2_schemas_update
}
+
pkg_postrm() {
gnome2_icon_cache_update
gnome2_schemas_update
diff --git a/x11-misc/redshift/Manifest b/x11-misc/redshift/Manifest
index 905dd95b9ecf..5a75524a80bf 100644
--- a/x11-misc/redshift/Manifest
+++ b/x11-misc/redshift/Manifest
@@ -1,3 +1,3 @@
DIST redshift-1.11.tar.gz 543804 BLAKE2B 9921ed703555fda60c06df9425bf4423ce3891db60f41a1c4c4b4897e2506b8ad79e44f765e49b08db5549406008e12c412c6ecb2a07316cdec4b123fd11ef11 SHA512 bcdb4c120efec3955f4f91f1290db0679e987e25d6610bd90ee8540a96bb11338e36b10680736490ea0b7e9eca5bc195b51767a5badf0b80495dc3da44c4ed8c
-EBUILD redshift-1.11-r1.ebuild 1930 BLAKE2B cca145ca14b52ccfc189d806af1665cd1048d9190e8124e60fef2c2b1406367d79309b5ce397f4eb209f1dbbd0d78eb8500ece3a6ff8e6b5f379f671859891c9 SHA512 4ef6dd14ff5fc6ed77eaffde1d8ff31a3c8a3f042c5d3f21cd4a79424136397685d537780649f712755ff77a2a2a85a0c0d40f76f89afd563bdcd882cd11099f
+EBUILD redshift-1.11-r1.ebuild 1937 BLAKE2B 83e4aee509fa6dca39cc1cfc74c81fbf901021b89639f1734f80f6a923d05cbddc4de13e19c6280f28bac35fc35f0d022aa038faa169cc2a43a0f223e44a53d7 SHA512 7242c7db4820d64f9bef555121c1531c3ea041ddd42d5a917e756d6557d487436a4cb01719c444f68a8f6758fabd22d137672021cd92d1b81b6903c780a227fb
MISC metadata.xml 679 BLAKE2B eaffc3977a1254a59f5f0d66d0758a821a1bb64ab2ccc8d3f71577ce116f94978cd9b6b32d8477a5d67a21e970b1e5cadb4c2246765fd28266ed49c4d541eefe SHA512 45aa40561fbf6b96d68f46f1773eebfdfa60c07a6e3cb85272523f7e7663b10bfe55ede7c95a3377acee87e40dbb9a0c771c6c53352f9a81629e9bc6e30f56d7
diff --git a/x11-misc/redshift/redshift-1.11-r1.ebuild b/x11-misc/redshift/redshift-1.11-r1.ebuild
index f41d95dbc2ff..03db78ec91aa 100644
--- a/x11-misc/redshift/redshift-1.11-r1.ebuild
+++ b/x11-misc/redshift/redshift-1.11-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/jonls/redshift/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="appindicator geoclue gtk nls"
COMMON_DEPEND=">=x11-libs/libX11-1.4
diff --git a/x11-misc/xdotool/Manifest b/x11-misc/xdotool/Manifest
index 61fdeb585b43..6e553ae38be9 100644
--- a/x11-misc/xdotool/Manifest
+++ b/x11-misc/xdotool/Manifest
@@ -1,5 +1,5 @@
DIST xdotool-3.20150503.1.tar.gz 102125 BLAKE2B 3b34b69ab7843d49a5cc76129dca96664b8e548abd01acda03399d06b1a146169c78dff302932000fe72c578be60bc774e3e503980b408cab4bf17d71630151c SHA512 d8eb411490d2f4936d63cd459e3319f76faf6dd415a3c2c68446b5a98d24290794dbffd22fbccfef5acc7d8aec6ce92b2135ecb3e1178607fc7d5b1e1767ede1
DIST xdotool-3.20160805.1.tar.gz 105388 BLAKE2B b836bd9c408bc4f7de562a1dd1fe18142155dc486b01912462b6d1cebc5f3f4094a407556c9f50cafb4ca3a17149e6f69303706730aabdaf94abc6d4b817d351 SHA512 e27b1029ee954ea17643ed489a00a1856e5687b03772c0f10a8e50cde3c3c957b57a3ba9890005474a744a228ef4827a83770d6890479c37a1f98f4fd7b1ff6c
EBUILD xdotool-3.20150503.1-r1.ebuild 1298 BLAKE2B f2167214cce8182e0074d2a80670aa6b37ceb66dc612016e12b0d6abdd0d7d22913757ad7cdd5ddf05969e0fa6a1ce6806d25e89675efade5fd1440fbaec1859 SHA512 37ea78350290a4bdfdac0c238b491ec464484e8bdb4bd8f64b2688a9f56728a93ffed84f913a098d0aed6ed5a3323a68b3bc353cf6299dc76f596226afee230b
-EBUILD xdotool-3.20160805.1.ebuild 1365 BLAKE2B 2d177e439d2c2d3fbf42a82b2d5fd37dd0cb5e8a886def7a11ce776088f73154dc1acc52c03aa53df19afbb8ec28dcb842265c25a5490b33d1cded6a0d5b6304 SHA512 1012565f4e7e6752671b054a5b4cd28b8e8c24a76d358917a6173856618a21ca5652ff317d15eb47e1103f2e99fb10b83b9cb68aac158b2ffa0de58e6a693786
+EBUILD xdotool-3.20160805.1.ebuild 1372 BLAKE2B d4e158eebb713c6320fa01334013357d0220525c746d54af59b0c062dc3a85dfa36568d46c23caaa80fa4e7b0df3242bcd3be436ca686ada90817d48b734cbed SHA512 a95c1ae8864b983ac86ddda95571bf9a43de193eaa26bbd2e1f22e3e500081aa2cee63bd417315ce0fe8aa68913a7088978fd0960d8e9556f2f955d223927985
MISC metadata.xml 583 BLAKE2B 72181c8dfd9d575229c2e86ad0041311325f9103715be568d45915c3a69bc44ef30919146fcae3f74ea2dbf844cd62d94dc7fe5e0ef1969b84a764b4ccd30cc1 SHA512 7c09064d2334d1f6b4d488bd9aaf091e0b27a7e674f151c62bea6e988d58c71996cf20f5d63587e14903a80b5f93e77305d493b94fe03a68ab24fbf1a438df76
diff --git a/x11-misc/xdotool/xdotool-3.20160805.1.ebuild b/x11-misc/xdotool/xdotool-3.20160805.1.ebuild
index ab667f7dce1a..5fbc2ab8e123 100644
--- a/x11-misc/xdotool/xdotool-3.20160805.1.ebuild
+++ b/x11-misc/xdotool/xdotool-3.20160805.1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/jordansissel/xdotool/releases/download/v${PV}/${P}.t
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
IUSE="examples"
RDEPEND="