summaryrefslogtreecommitdiff
path: root/x11-misc/yabar
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/yabar')
-rw-r--r--x11-misc/yabar/Manifest3
-rw-r--r--x11-misc/yabar/metadata.xml21
-rw-r--r--x11-misc/yabar/yabar-0.4.0_p20190316.ebuild61
3 files changed, 85 insertions, 0 deletions
diff --git a/x11-misc/yabar/Manifest b/x11-misc/yabar/Manifest
new file mode 100644
index 000000000000..e178c15c11f8
--- /dev/null
+++ b/x11-misc/yabar/Manifest
@@ -0,0 +1,3 @@
+DIST yabar-0.4.0_p20190316.tar.gz 892725 BLAKE2B eb14b06327533034756885c68ab03b1ff049c987d1dac6d083c553646cd178210429d9457c1067db3211fcb39e9814a260aed201dea4e6410544b9247c5dee93 SHA512 f93250605c5b56d64c7ec6a7e7faa6120cdc06191ddafb13822875fd98b1b7a1822d9b93b62c49c302b1d4bffb14a200feed937efb0b11711de7159ce83eb7c5
+EBUILD yabar-0.4.0_p20190316.ebuild 1408 BLAKE2B e828f9dd0a7b6bc16eca292b6b8202974d23e314c72ad2ca23c7238f7c8fa526450f6771afdd94e5d3fc6ef7f3bac848f875fa1a1474661f4e6750ac8adf5c66 SHA512 d95dbcb0b464aa297460368e2ed8703663edcd2c82bd2841a240469d308f71b903aa0f03adabdbc7c7574b9d2ea516042bd6aae198f88b1d1f4c8d97b861de11
+MISC metadata.xml 585 BLAKE2B 4d79040e69737a752069c4fc672996c9121347e6813a6f4ec31202685968d1bca500cf428e0ce601f63570abf64dd23eba1fe625b31552602f29809a0776d9c0 SHA512 8974255efba23f15dd84b4a158b82bf2a958de54f09b4ec8a85021d771814fddc482447b1df366227224981d7bd12d13c50b0b1f80b57db83ba023f55c177a2b
diff --git a/x11-misc/yabar/metadata.xml b/x11-misc/yabar/metadata.xml
new file mode 100644
index 000000000000..e6d7b0c55687
--- /dev/null
+++ b/x11-misc/yabar/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lillyjsm@gmail.com</email>
+ <name>Jake Lilly</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="playerctl">
+ Uses <pkg>media-sound/playerctl</pkg> to retrieve the name of the currently
+ played song
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">geommer/yabar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/yabar/yabar-0.4.0_p20190316.ebuild b/x11-misc/yabar/yabar-0.4.0_p20190316.ebuild
new file mode 100644
index 000000000000..b9fe19029872
--- /dev/null
+++ b/x11-misc/yabar/yabar-0.4.0_p20190316.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="a0d3fdfed992149b741eb8fcf53f02b5d1a6142e"
+DESCRIPTION="A modern and lightweight status bar for X window managers"
+HOMEPAGE="https://github.com/geommer/yabar"
+SRC_URI="https://github.com/geommer/yabar/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="playerctl"
+
+DEPEND="
+ app-text/asciidoc
+ dev-libs/libconfig:=
+ media-libs/alsa-lib
+ net-wireless/wireless-tools
+ x11-libs/cairo[xcb]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango
+ x11-libs/xcb-util-wm
+ playerctl? ( media-sound/playerctl )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+ # Respect CFLAGS and LDFLAGS
+ # Declare VERSION without relying on git
+ # Replace playerctl dependency option with basename
+ sed -i -e "s:-flto -O2::g" -e "s:-Wall::" \
+ -e "s:\$(shell git describe):0.4.0-179-ga0d3fdf:" \
+ -e "s:^DEPS += playerctl-1.0:DEPS += playerctl:" \
+ Makefile || die "Failed to update Makefile"
+}
+
+src_compile() {
+ if use playerctl; then
+ emake PLAYERCTL=1
+ else
+ emake
+ fi
+}
+
+src_install() {
+ default
+ docinto examples
+ dodoc examples/example.config
+ docompress -x "/usr/share/doc/${PF}/examples"
+}
+
+pkg_postinst() {
+ elog "An example yabar configuration file can be found in"
+ elog "the following path: /usr/share/doc/${PF}/examples"
+}