summaryrefslogtreecommitdiff
path: root/x11-misc/xkblayout-state/xkblayout-state-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xkblayout-state/xkblayout-state-9999.ebuild')
-rw-r--r--x11-misc/xkblayout-state/xkblayout-state-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/xkblayout-state/xkblayout-state-9999.ebuild b/x11-misc/xkblayout-state/xkblayout-state-9999.ebuild
new file mode 100644
index 000000000000..b92c94a33662
--- /dev/null
+++ b/x11-misc/xkblayout-state/xkblayout-state-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="A small program to get/set the current XKB layout"
+HOMEPAGE="https://github.com/nonpop/xkblayout-state"
+EGIT_REPO_URI="https://github.com/nonpop/xkblayout-state.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install
+}