summaryrefslogtreecommitdiff
path: root/x11-misc/wmname/files/wmname-0.1-buildsystem.patch
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/wmname/files/wmname-0.1-buildsystem.patch')
-rw-r--r--x11-misc/wmname/files/wmname-0.1-buildsystem.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/wmname/files/wmname-0.1-buildsystem.patch b/x11-misc/wmname/files/wmname-0.1-buildsystem.patch
new file mode 100644
index 000000000000..bee2131d9bef
--- /dev/null
+++ b/x11-misc/wmname/files/wmname-0.1-buildsystem.patch
@@ -0,0 +1,26 @@
+--- wmname-0.1/config.mk
++++ wmname-0.1/config.mk
+@@ -16,9 +16,9 @@
+
+ # flags
+ CPPFLAGS = -DVERSION=\"${VERSION}\"
+-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+-LDFLAGS = -s ${LIBS}
++CFLAGS += -std=c99 -pedantic ${INCS} ${CPPFLAGS}
++LDFLAGS += ${LIBS}
+
+ # compiler and linker
+-CC = cc
+-LD = ${CC}
++CC ?= cc
++LD ?= ${CC}
+--- wmname-0.1/Makefile
++++ wmname-0.1/Makefile
+@@ -23,7 +23,6 @@
+ wmname: ${OBJ}
+ @echo LD $@
+ @${LD} -o $@ ${OBJ} ${LDFLAGS}
+- @strip $@
+
+ clean:
+ @echo cleaning