summaryrefslogtreecommitdiff
path: root/x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch')
-rw-r--r--x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch b/x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch
new file mode 100644
index 000000000000..bc8a96130575
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch
@@ -0,0 +1,23 @@
+--- a/src/test/CMakeLists.txt
++++ b/src/test/CMakeLists.txt
+@@ -14,20 +14,5 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+-include_directories(
+- ../../ext/gtest
+- ../../ext/gtest/include
+- ../../ext/gmock
+- ../../ext/gmock/include)
+-
+-add_library(gtest STATIC ../../ext/gtest/src/gtest-all.cc)
+-add_library(gmock STATIC ../../ext/gmock/src/gmock-all.cc)
+-
+-if (UNIX)
+- # ignore warnings in gtest and gmock
+- set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-w")
+- set_target_properties(gmock PROPERTIES COMPILE_FLAGS "-w")
+-endif()
+-
+ add_subdirectory(integtests)
+ add_subdirectory(unittests)