summaryrefslogtreecommitdiff
path: root/x11-misc/synergy/files/synergy-1.4.17_p2055-cryptopp.patch
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/synergy/files/synergy-1.4.17_p2055-cryptopp.patch')
-rw-r--r--x11-misc/synergy/files/synergy-1.4.17_p2055-cryptopp.patch96
1 files changed, 0 insertions, 96 deletions
diff --git a/x11-misc/synergy/files/synergy-1.4.17_p2055-cryptopp.patch b/x11-misc/synergy/files/synergy-1.4.17_p2055-cryptopp.patch
deleted file mode 100644
index 59f85a9c29a0..000000000000
--- a/x11-misc/synergy/files/synergy-1.4.17_p2055-cryptopp.patch
+++ /dev/null
@@ -1,96 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -145,6 +145,10 @@
- check_type_size(long SIZEOF_LONG)
- check_type_size(short SIZEOF_SHORT)
-
-+ set(CMAKE_REQUIRED_LIBRARIES crypto++)
-+ set(CMAKE_REQUIRED_LIBRARIES)
-+ set(CMAKE_INCLUDE_DIRECTORIES)
-+
- # pthread is used on both Linux and Mac
- check_library_exists("pthread" pthread_create "" HAVE_PTHREAD)
- if (HAVE_PTHREAD)
---- a/ext/CMakeLists.txt
-+++ b/ext/CMakeLists.txt
-@@ -13,47 +13,6 @@
- # You should have received a copy of the GNU General Public License
- # along with this program. If not, see <http://www.gnu.org/licenses/>.
-
--set(cryptopp_dir cryptopp562)
--
--# only compile the crypto++ files we need.
--set(cryptopp_src
-- ${cryptopp_dir}/3way.cpp
-- ${cryptopp_dir}/algparam.cpp
-- ${cryptopp_dir}/asn.cpp
-- ${cryptopp_dir}/authenc.cpp
-- ${cryptopp_dir}/basecode.cpp
-- ${cryptopp_dir}/cpu.cpp
-- ${cryptopp_dir}/cryptlib.cpp
-- ${cryptopp_dir}/des.cpp
-- ${cryptopp_dir}/dessp.cpp
-- ${cryptopp_dir}/dll.cpp
-- ${cryptopp_dir}/ec2n.cpp
-- ${cryptopp_dir}/ecp.cpp
-- ${cryptopp_dir}/filters.cpp
-- ${cryptopp_dir}/fips140.cpp
-- ${cryptopp_dir}/gcm.cpp
-- ${cryptopp_dir}/gf2n.cpp
-- ${cryptopp_dir}/gfpcrypt.cpp
-- ${cryptopp_dir}/hex.cpp
-- ${cryptopp_dir}/hmac.cpp
-- ${cryptopp_dir}/hrtimer.cpp
-- ${cryptopp_dir}/integer.cpp
-- ${cryptopp_dir}/iterhash.cpp
-- ${cryptopp_dir}/misc.cpp
-- ${cryptopp_dir}/modes.cpp
-- ${cryptopp_dir}/mqueue.cpp
-- ${cryptopp_dir}/nbtheory.cpp
-- ${cryptopp_dir}/oaep.cpp
-- ${cryptopp_dir}/osrng.cpp
-- ${cryptopp_dir}/pubkey.cpp
-- ${cryptopp_dir}/queue.cpp
-- ${cryptopp_dir}/randpool.cpp
-- ${cryptopp_dir}/rdtables.cpp
-- ${cryptopp_dir}/rijndael.cpp
-- ${cryptopp_dir}/rng.cpp
-- ${cryptopp_dir}/sha.cpp
--)
--
- # if 64-bit windows, compile asm file.
- if (CMAKE_CL_64)
- list(APPEND cryptopp_src ${cryptopp_dir}/x64dll.asm ${cryptopp_dir}/x64masm.asm)
-@@ -87,10 +46,3 @@
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=${CRYPTOPP_ARCH}")
- endif()
- endif()
--
--add_library(cryptopp STATIC ${cryptopp_src})
--
--if (UNIX)
-- # ignore warnings in crypto++
-- set_target_properties(cryptopp PROPERTIES COMPILE_FLAGS "-w")
--endif()
---- a/src/lib/io/CryptoMode_cryptopp.h
-+++ b/src/lib/io/CryptoMode_cryptopp.h
-@@ -25,6 +25,6 @@
- # pragma GCC system_header
- #endif
-
--#include <cryptopp562/gcm.h>
--#include <cryptopp562/modes.h>
--#include <cryptopp562/aes.h>
-+#include <crypto++/gcm.h>
-+#include <crypto++/modes.h>
-+#include <crypto++/aes.h>
---- a/src/lib/io/CryptoStream_cryptopp.h
-+++ b/src/lib/io/CryptoStream_cryptopp.h
-@@ -25,5 +25,5 @@
- # pragma GCC system_header
- #endif
-
--#include <cryptopp562/osrng.h>
--#include <cryptopp562/sha.h>
-+#include <crypto++/osrng.h>
-+#include <crypto++/sha.h>