summaryrefslogtreecommitdiff
path: root/x11-misc/sunflower/sunflower-0.4_p20200716-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sunflower/sunflower-0.4_p20200716-r2.ebuild')
-rw-r--r--x11-misc/sunflower/sunflower-0.4_p20200716-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-misc/sunflower/sunflower-0.4_p20200716-r2.ebuild b/x11-misc/sunflower/sunflower-0.4_p20200716-r2.ebuild
new file mode 100644
index 000000000000..40f32e2ea597
--- /dev/null
+++ b/x11-misc/sunflower/sunflower-0.4_p20200716-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1 xdg
+
+DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
+HOMEPAGE="https://github.com/MeanEYE/Sunflower
+ https://sunflower-fm.org/"
+SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+"