summaryrefslogtreecommitdiff
path: root/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild')
-rw-r--r--x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild b/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild
index 53c9511c8cc6..072b2dfda9b1 100644
--- a/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild
+++ b/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit flag-o-matic
DESCRIPTION="tool that allows you to tune SiS drivers from X"
@@ -10,8 +11,9 @@ SRC_URI="http://www.winischhofer.net/sis/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 x86"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
dev-libs/glib:2
x11-libs/gtk+:2
@@ -21,10 +23,11 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
- virtual/pkgconfig
x11-base/xorg-proto
"
-DOCS="AUTHORS ChangeLog NEWS README"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
PATCHES=(
"${FILESDIR}"/${P}-no-xv.patch
)
@@ -32,5 +35,5 @@ PATCHES=(
src_configure() {
append-libs -lm
econf \
- --with-xv-path="${EROOT}/usr/$(get_libdir)"
+ --with-xv-path="${EPREFIX}/usr/$(get_libdir)"
}