summaryrefslogtreecommitdiff
path: root/x11-misc/sent/sent-1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sent/sent-1-r1.ebuild')
-rw-r--r--x11-misc/sent/sent-1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/sent/sent-1-r1.ebuild b/x11-misc/sent/sent-1-r1.ebuild
new file mode 100644
index 000000000000..8324b45871a4
--- /dev/null
+++ b/x11-misc/sent/sent-1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Simple plaintext presentation tool"
+HOMEPAGE="https://tools.suckless.org/sent/"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXft
+"
+RDEPEND="
+ ${DEPEND}
+ !savedconfig? ( media-gfx/farbfeld )
+"
+S=${WORKDIR}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|^ @| |g' \
+ -e 's|@${CC}|$(CC)|g' \
+ -e '/^ echo/d' \
+ Makefile || die
+
+ restore_config config.h
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ save_config config.h
+}