summaryrefslogtreecommitdiff
path: root/x11-misc/rendercheck/rendercheck-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/rendercheck/rendercheck-9999.ebuild')
-rw-r--r--x11-misc/rendercheck/rendercheck-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/rendercheck/rendercheck-9999.ebuild b/x11-misc/rendercheck/rendercheck-9999.ebuild
new file mode 100644
index 000000000000..89bb8e72ef8d
--- /dev/null
+++ b/x11-misc/rendercheck/rendercheck-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MODULE=test/
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3 meson
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Tests for compliance with X RENDER extension"
+HOMEPAGE="https://www.x.org/wiki/ https://gitlab.freedesktop.org/xorg/test/rendercheck"
+LICENSE="MIT GPL-2+"
+
+RDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXext
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="virtual/pkgconfig"
+
+# Override xorg-3's src_prepare
+src_prepare() {
+ default
+}