summaryrefslogtreecommitdiff
path: root/x11-misc/qt5ct/qt5ct-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/qt5ct/qt5ct-1.0.ebuild')
-rw-r--r--x11-misc/qt5ct/qt5ct-1.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/x11-misc/qt5ct/qt5ct-1.0.ebuild b/x11-misc/qt5ct/qt5ct-1.0.ebuild
deleted file mode 100644
index 5ec0690f1e18..000000000000
--- a/x11-misc/qt5ct/qt5ct-1.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit qmake-utils
-
-DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
-HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
-SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="+dbus"
-
-RDEPEND="
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5=
- dev-qt/qtwidgets:5
- dbus? (
- dev-qt/qtdbus:5
- dev-qt/qtgui:5[dbus]
- )
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
-"
-
-src_configure() {
- eqmake5 DISABLE_DBUS=$(usex dbus 0 1)
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
- einstalldocs
-
- newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- ewarn "qt5ct configuration won't be applied to the currently running sessions."
- ewarn "Please relogin."
- fi
- if ! has_version 'dev-qt/qtsvg:5'; then
- elog
- elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
- elog
- fi
-}