summaryrefslogtreecommitdiff
path: root/x11-misc/qps/qps-2.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/qps/qps-2.3.0.ebuild')
-rw-r--r--x11-misc/qps/qps-2.3.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/qps/qps-2.3.0.ebuild b/x11-misc/qps/qps-2.3.0.ebuild
new file mode 100644
index 000000000000..37c0a3392326
--- /dev/null
+++ b/x11-misc/qps/qps-2.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI Process Manager"
+HOMEPAGE="https://lxqt.github.io/"
+SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+ QPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=lxqt-base/liblxqt-0.17.0
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}