summaryrefslogtreecommitdiff
path: root/x11-misc/obconf-qt/obconf-qt-0.16.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/obconf-qt/obconf-qt-0.16.3.ebuild')
-rw-r--r--x11-misc/obconf-qt/obconf-qt-0.16.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/obconf-qt/obconf-qt-0.16.3.ebuild b/x11-misc/obconf-qt/obconf-qt-0.16.3.ebuild
new file mode 100644
index 000000000000..7c66c3dd88fd
--- /dev/null
+++ b/x11-misc/obconf-qt/obconf-qt-0.16.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI Openbox Configuration Tool"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.8.0
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-wm/openbox:3
+"
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}