summaryrefslogtreecommitdiff
path: root/x11-misc/mozo
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/mozo')
-rw-r--r--x11-misc/mozo/Manifest2
-rw-r--r--x11-misc/mozo/mozo-1.24.1.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/x11-misc/mozo/Manifest b/x11-misc/mozo/Manifest
index 33b28a89935f..9d51305baf39 100644
--- a/x11-misc/mozo/Manifest
+++ b/x11-misc/mozo/Manifest
@@ -1,3 +1,5 @@
DIST mozo-1.24.0.tar.xz 228180 BLAKE2B 6eb880b82dcb608f84efd8df74e77812f9da68dfa877ec896c6f04fa18088e8e4a82641c715e3620201dbb8a1bea8bb4ded09dd72f50770edae09c1326cbf453 SHA512 e0d217d2e7bb7d2c8df777e51bfb20e8bf4fa1bee0f9f3a9348ec1c8501b386a4afbd8848735ecfa61a0f9576382d784d3ef5b884a2a34af6ba33d3a126fe193
+DIST mozo-1.24.1.tar.xz 231032 BLAKE2B 27938aca9810943d19074cc5761ac58bb1dc2c1918b2fefea983f7a1b8788cb555311555515bb4387944c7b48a309de4a80da9003d212ca68ea257fa9ab06c8d SHA512 04b7e93e7302b46a3959f78655de4a6f8b17896be2c506c0e8a9041a9a2d5247e8c2ac00b5c8f86616f6c39a533584923feacfe4b81ae58d41080632af2a24bd
EBUILD mozo-1.24.0-r1.ebuild 1306 BLAKE2B 7a74f935c11b69f25805582fa9ecbce944a2dde952edf57e400fc428172e397a6502dbd28b2f9d7ef39350e174b59bdb99cbbe0e50768534714ef6d9ccfe45c3 SHA512 e88938967f3cb8a244b36d83d7c0ddc1d719a01c23d04d447a2d388a267ee23652093a5aaa5f85fac0f8c79bfe7d0845acce4085ef2cde0c11e6fda0e6a41196
+EBUILD mozo-1.24.1.ebuild 1313 BLAKE2B 5f8716e7d773671aa998e01fa03af887a74823ae585b3af22094d8e3122b2b78c94cd1391e6abd235e6ecdecd64fdd0bfb225ff7fac11baaa1264883243a5919 SHA512 134f5a1dc40635b89b9fd0dc8b8b74fb3d6f2a04e1f8e7b90e99c7d22a4d315be1b5e05bad83a0d74ab6a0a41aca6bd7198cfb97d5c36f870145053293e09957
MISC metadata.xml 333 BLAKE2B 9901ffa7d882f0f741c95670130db70920ebbe94af75b8d9b72f48f8eb1b48d9425b7ff49dafbe001e5287ff3eafd2d60a8760a262ab6601fecc63642e242591 SHA512 eb3bc4b3cf1cfde5f96cd414138790deae0435e8ba41576e1e44b150defd5fdda0b921d4dbb0798b9653ad5aa7690247fb69cd25d03752f8bde8017419596a76
diff --git a/x11-misc/mozo/mozo-1.24.1.ebuild b/x11-misc/mozo/mozo-1.24.1.ebuild
new file mode 100644
index 000000000000..2b73ccc26492
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.24.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_REQ_USE="xml"
+
+inherit mate python-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2+ GPL-3+ LGPL-2+ LGPL-2.1+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.21.0[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ !!x11-misc/mate-menu-editor
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ python_optimize
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}