summaryrefslogtreecommitdiff
path: root/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r2.ebuild')
-rw-r--r--x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r2.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r2.ebuild b/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r2.ebuild
index 16aac45e5d34..823e10812860 100644
--- a/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r2.ebuild
+++ b/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0-r2.ebuild
@@ -1,31 +1,28 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib
MY_P=${P/.0/}
DESCRIPTION="Mute/unmute and other macros for LINEAK"
HOMEPAGE="http://lineak.sourceforge.net"
SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ppc x86"
IUSE="debug"
-RDEPEND="
- =x11-misc/lineakd-${PV}*
-"
+RDEPEND="=x11-misc/lineakd-${PV}*"
DEPEND="
${RDEPEND}
x11-base/xorg-proto
"
-S=${WORKDIR}/${MY_P}
-DOCS=(
- AUTHORS README
-)
+
+DOCS=( AUTHORS README )
+
PATCHES=(
"${FILESDIR}"/${P}-gcc43.patch
"${FILESDIR}"/${P}-gcc47.patch
@@ -40,6 +37,6 @@ src_prepare() {
src_configure() {
econf \
$(use_enable debug) \
- --with-lineak-plugindir="${EROOT}/usr/$(get_libdir)/lineakd" \
+ --with-lineak-plugindir="${EPREFIX}/usr/$(get_libdir)/lineakd" \
USER_LDFLAGS="${LDFLAGS}"
}