summaryrefslogtreecommitdiff
path: root/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/libinput-gestures/libinput-gestures-9999.ebuild')
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild b/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
index 73b3a4132933..2f4a08da79af 100644
--- a/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
+++ b/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{5..7} )
-inherit gnome2-utils python-single-r1
+inherit python-single-r1 xdg-utils
DESCRIPTION="Actions gestures on your touchpad using libinput"
HOMEPAGE="https://github.com/bulletmark/libinput-gestures"
@@ -24,8 +24,8 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
>=dev-libs/libinput-1.8.0
- x11-misc/xdotool
- x11-misc/wmctrl"
+ x11-misc/wmctrl
+ x11-misc/xdotool"
DEPEND=">=dev-libs/libinput-1.8.0
dev-util/desktop-file-utils"
@@ -39,7 +39,7 @@ src_prepare() {
src_test() { :; }
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
elog "You must be in the input group to read the touchpad device."
@@ -52,5 +52,5 @@ pkg_postinst() {
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}