summaryrefslogtreecommitdiff
path: root/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/libinput-gestures/libinput-gestures-9999.ebuild')
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-9999.ebuild27
1 files changed, 22 insertions, 5 deletions
diff --git a/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild b/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
index 17387ae8a397..39fb049c736d 100644
--- a/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
+++ b/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
@@ -5,16 +5,20 @@ EAPI=6
PYTHON_COMPAT=( python{3_4,3_5,3_6} )
-inherit git-r3 python-single-r1
+inherit gnome2-utils python-single-r1
DESCRIPTION="Actions gestures on your touchpad using libinput"
-HOMEPAGE="https://github.com/bulletmark/${PN}"
-EGIT_REPO_URI="https://github.com/bulletmark/${PN}.git"
-SRC_URI=""
+HOMEPAGE="https://github.com/bulletmark/libinput-gestures"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bulletmark/${PN}.git"
+else
+ SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
IUSE="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -26,7 +30,16 @@ DEPEND=">=dev-libs/libinput-1.8.0
dev-util/desktop-file-utils
test? ( dev-python/flake8[${PYTHON_USEDEP}] )"
+src_prepare() {
+ default
+
+ # Fix docdir installation path
+ sed '/^DOCDIR/s@$NAME@${PF}@' -i libinput-gestures-setup || die
+}
+
pkg_postinst() {
+ gnome2_icon_cache_update
+
elog "You must be in the input group to read the touchpad device."
if ! has_version x11-libs/gtk+:3 ; then
@@ -36,3 +49,7 @@ pkg_postinst() {
elog "${PN}-setup script supports Plasma 5 via kde-plasma/kde-cli-tools:5."
fi
}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}