summaryrefslogtreecommitdiff
path: root/x11-misc/imake/imake-1.0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/imake/imake-1.0.9.ebuild')
-rw-r--r--x11-misc/imake/imake-1.0.9.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-misc/imake/imake-1.0.9.ebuild b/x11-misc/imake/imake-1.0.9.ebuild
new file mode 100644
index 000000000000..90e00308d59d
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+inherit toolchain-funcs xorg-3
+
+DESCRIPTION="C preprocessor interface to the make utility"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="x11-misc/xorg-cf-files"
+DEPEND="x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.8-cpp-args.patch
+ "${FILESDIR}"/${PN}-1.0.9-no-get-gcc.patch
+ "${FILESDIR}"/${PN}-1.0.8-respect-LD.patch
+ "${FILESDIR}"/${PN}-1.0.8-xmkmf-pass-cc-ld.patch
+)
+
+src_configure() {
+ econf CPP="$(tc-getPROG CPP cpp)" #722046
+}