summaryrefslogtreecommitdiff
path: root/x11-misc/i3status
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/i3status')
-rw-r--r--x11-misc/i3status/Manifest6
-rw-r--r--x11-misc/i3status/files/i3status-2.11-pulseaudio.patch42
-rw-r--r--x11-misc/i3status/i3status-2.11.ebuild44
-rw-r--r--x11-misc/i3status/metadata.xml19
4 files changed, 111 insertions, 0 deletions
diff --git a/x11-misc/i3status/Manifest b/x11-misc/i3status/Manifest
new file mode 100644
index 000000000000..2b35db054535
--- /dev/null
+++ b/x11-misc/i3status/Manifest
@@ -0,0 +1,6 @@
+AUX i3status-2.11-pulseaudio.patch 1085 SHA256 27ed5a938ecece3336f916f31fe2996ea65e1f14a4730084a34cb773b4cdd333 SHA512 d08f22209598567af425aea2e387dfaec0312e47a4ae9882818097e84d3ff59f671132242f6f8d6620c3d63b3b0e1c9054d26f416804608fe657872dea1c9678 WHIRLPOOL 4c75dfba704bc6b85b6f1f31650099498a9c4eef96b01d70cf4fa251b3eda09ec41d0fb29e4c9b98388dfb250a3a92e1e91ed102f16d94fce2cf4380cce4eca6
+DIST i3status-2.11.tar.bz2 54970 SHA256 98db7e730f0ce908eb656ac10d713ae6a885676621391d54f00b719752f18c5f SHA512 37d2549649178122fab7411a3c714ae041d9c726c140002ec6ccd1a4f2e28af618ca28af9aa3bc45d0cafda0b25dd438c9ed4c3739ddcc0511e19305657730f0 WHIRLPOOL d676b9a66139778dcfe5ea6418bd60ebf89afe3dbce0a14d34f6d46ec52ccf0900727c4727e8fd6f03e6d0466af07f69f00a6da0b6e997bbdf9d57dbe2a8f7bc
+EBUILD i3status-2.11.ebuild 1046 SHA256 169bed1a8bf3c7867fb81ef42d7783f320d9f8eb34cabb01ef53348577b2a8de SHA512 4a124f32c3a320e5b14e7406bdf6619fcfe4c1b86e71c0bab2701067c3401d7184c926c45da25cfbfd3b9766559968dfca1edbd8e62d521c815d84abfa72f610 WHIRLPOOL dcbe8f75a6f6fbffcc08ad48953d1bb0f7254384cae957a4aa34697107bbb719328c945286299afcdbceebab39ecfae2e96530ce5a7db5879d5e18349cb7a6a9
+MISC ChangeLog 3582 SHA256 38196f14276f4571a49a0d6c71be12798329527ef8ae8fafc740baacb2eddb19 SHA512 e18c50236e65f424a99dc85404400b69a0945ff237e2a972f82577050c1c9c8e20a44954bd546646fb8684457be1bea90fe0307c4ca6050868a605e70cdc69e9 WHIRLPOOL 0d649dd21d70d11cee465ebc92800278eba7291d397c3e47c2ed5830b5befd3f0641bd66c8f33eb62521dbcf82f5e0ae2c799774fd49c0907192ddb9d2f79b62
+MISC ChangeLog-2015 3003 SHA256 cf1687a2fc9d832a9367f6571966982d3b9c04ff24030a3f928ed0032abdbf14 SHA512 34a7e43cfc0945fe16c5e0a142f6960d7deb2552b87e3c13165734e473213673ea96d45af63a84f9907f3276ef54a76879b9d6d30f134a549b9f7f4211e415b7 WHIRLPOOL 9a704e813776df4ea7989a11b3bab76e8fe36edab0a3a6973db9a2e363014c903d0c181ebc4c0b265425e0835311df58ed77f964fcd6e65ebe7cdf65f242046d
+MISC metadata.xml 923 SHA256 36533d9be298b48bdb9b89e9668811e64017769c60a6cf20f016c05623a8b91a SHA512 767566a72041c13afd546301ad688053e7855fa90c036d381eb03ba4d53caa573809b9ba7433c4484004f3aed800a0b9232c6861e347a1b75ed04f56cb37240b WHIRLPOOL 1d1d6603652b3eb2af6236c8417a7ff8c63faac1a2e3ddda40d4c52af64e3d9f22fdd142dd20d1ca0955dfaa75a4b7d29de6faef63fceeae9132a452e7eecdb3
diff --git a/x11-misc/i3status/files/i3status-2.11-pulseaudio.patch b/x11-misc/i3status/files/i3status-2.11-pulseaudio.patch
new file mode 100644
index 000000000000..2447f16f9339
--- /dev/null
+++ b/x11-misc/i3status/files/i3status-2.11-pulseaudio.patch
@@ -0,0 +1,42 @@
+diff --git a/Makefile b/Makefile
+index 3084ae7..7ea1964 100644
+--- a/Makefile
++++ b/Makefile
+@@ -58,6 +57,10 @@ ifeq ($(OS),NetBSD)
+ LIBS+=-lprop
+ endif
+
++ifeq ($(OS),OpenBSD)
++LIBS+=-lpthread
++endif
++
+ # This probably applies for any pkgsrc based system
+ ifneq (, $(filter $(OS), NetBSD DragonFly))
+ CFLAGS+=-I/usr/pkg/include/
+@@ -79,9 +82,12 @@ CFLAGS += -idirafter yajl-fallback
+ OBJS:=$(sort $(wildcard src/*.c *.c))
+ OBJS:=$(OBJS:.c=.o)
+
+-ifeq ($(OS),OpenBSD)
++PULSE ?= 1
++ifeq ($(PULSE),0)
+ OBJS:=$(filter-out src/pulse.o, $(OBJS))
+ LIBS:=$(filter-out -lpulse, $(LIBS))
++else
++CPPFLAGS+=-DPULSE
+ endif
+
+ src/%.o: src/%.c include/i3status.h
+diff --git a/src/print_volume.c b/src/print_volume.c
+index 51e84f3..9e015c0 100644
+--- a/src/print_volume.c
++++ b/src/print_volume.c
+@@ -61,7 +61,7 @@ void print_volume(yajl_gen json_gen, char *buffer, const char *fmt, const char *
+ free(instance);
+ }
+
+-#ifndef __OpenBSD__
++#if !defined(__OpenBSD__) && defined(PULSE)
+ /* Try PulseAudio first */
+
+ /* If the device name has the format "pulse[:N]" where N is the
diff --git a/x11-misc/i3status/i3status-2.11.ebuild b/x11-misc/i3status/i3status-2.11.ebuild
new file mode 100644
index 000000000000..f17c7c3335ef
--- /dev/null
+++ b/x11-misc/i3status/i3status-2.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs fcaps
+
+DESCRIPTION="generates a status bar for dzen2, xmobar or similar"
+HOMEPAGE="http://i3wm.org/i3status/"
+SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="pulseaudio"
+
+RDEPEND="dev-libs/confuse:=
+ dev-libs/libnl:3
+ >=dev-libs/yajl-2.0.2
+ media-libs/alsa-lib
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-pulseaudio.patch
+ sed -e "/@echo/d" -e "s:@\$(:\$(:g" -e "/setcap/d" \
+ -e '/CFLAGS+=-g/d' -i Makefile || die
+ eapply_user
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PULSE=$(usex pulseaudio 1 0)
+}
+
+pkg_postinst() {
+ fcaps cap_net_admin usr/bin/${PN}
+ einfo "${PN} can be used with any of the following programs:"
+ einfo " i3bar (x11-wm/i3)"
+ einfo " x11-misc/xmobar"
+ einfo " x11-misc/dzen"
+ einfo "Please refer to manual: man ${PN}"
+}
diff --git a/x11-misc/i3status/metadata.xml b/x11-misc/i3status/metadata.xml
new file mode 100644
index 000000000000..59a2a28f64b5
--- /dev/null
+++ b/x11-misc/i3status/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>desktop-misc@gentoo.org</email>
+ <name>Gentoo Desktop Miscellaneous Project</name>
+ </maintainer>
+ <longdescription>
+ i3status is a small program (about 1500 SLOC) for generating a status bar for
+ dzen2, xmobar or similar programs. It is designed to be very efficient by
+ issuing a very small number of system calls, as one generally wants to update
+ such a status line every second. This ensures that even under high load, your
+ status bar is updated correctly. Also, it saves a bit of energy by not hogging
+ your CPU as much as spawning the corresponding amount of shell commands would.
+ </longdescription>
+ <use>
+ <flag name="filecaps">Linux capabilities library is required for i3status to be able to read net bandwith</flag>
+ </use>
+</pkgmetadata>