summaryrefslogtreecommitdiff
path: root/x11-misc/gccmakedep/gccmakedep-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gccmakedep/gccmakedep-9999.ebuild')
-rw-r--r--x11-misc/gccmakedep/gccmakedep-9999.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/x11-misc/gccmakedep/gccmakedep-9999.ebuild b/x11-misc/gccmakedep/gccmakedep-9999.ebuild
deleted file mode 100644
index 42c149df8c52..000000000000
--- a/x11-misc/gccmakedep/gccmakedep-9999.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="create dependencies in makefiles using 'gcc -M'"
-HOMEPAGE="https://www.x.org/wiki/ https://gitlab.freedesktop.org/xorg/util/gccmakedep"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/util/gccmakedep.git"
- inherit autotools git-r3
- # x11-misc/util-macros only required on live ebuilds
- LIVE_DEPEND=">=x11-misc/util-macros-1.18"
-else
- SRC_URI="https://www.x.org/releases/individual/util/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-DEPEND="
- ${LIVE_DEPEND}
- x11-base/xorg-proto
-"
-
-src_prepare() {
- default
- [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-src_configure() {
- local econfargs=(
- --disable-selective-werror
- )
-
- econf "${econfargs[@]}"
-}