summaryrefslogtreecommitdiff
path: root/x11-misc/evolvotron
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/evolvotron')
-rw-r--r--x11-misc/evolvotron/Manifest3
-rw-r--r--x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild54
-rw-r--r--x11-misc/evolvotron/evolvotron-0.7.1.ebuild3
3 files changed, 58 insertions, 2 deletions
diff --git a/x11-misc/evolvotron/Manifest b/x11-misc/evolvotron/Manifest
index ea809a5c9308..781429a0144f 100644
--- a/x11-misc/evolvotron/Manifest
+++ b/x11-misc/evolvotron/Manifest
@@ -1,3 +1,4 @@
DIST evolvotron-0.7.1.tar.gz 179516 BLAKE2B b73c813fdf134e0e4c7882e06a12bc06acfb6dcdf4a38043c4c30027bf00da10df85d6877abdbd8ca6393496038ba9fa0c32a16b0f37dd14d72cc63c00a17d1c SHA512 74f48dc0881a82d999ccc910df026da80fcc46a906fe2fbb8edbae50a1fa42a3379087f00dd21fd9e5d69cee7c6fc745b80f8703b1af1ebc3a1cdb52ffbe16e9
-EBUILD evolvotron-0.7.1.ebuild 915 BLAKE2B 796e1d56e5d036c21432a325260bb467a00c8c921a912c9ce6fa1361c9e19f8b653612405c381b69022bfc87df3ea36c0fbc168aed0f00aa6cc92896e5a95be0 SHA512 b313b4b261973140839382dc561fe62811797a031c35bdc45cc025beded0f99ffc46f09adf87de111a0e4b27ecda33ca518b8b9a0a117cb3b47c292670704a9e
+EBUILD evolvotron-0.7.1-r1.ebuild 880 BLAKE2B b22113e22bf41363133673ae7c29e11a74adb1df6c20e7a008a574216db96049e653a1cdc815816063fafc7e24bfbb64d9091aa08d50501dc8a5ea6973d60b51 SHA512 a63a10863fc0b0d501000674cc18a477c9b5da5afc46bbd85c58d38db2de4a5269280e79b9676d5a9c4643a8e0686811713605d04320d8a3293001ec9ffd8b11
+EBUILD evolvotron-0.7.1.ebuild 932 BLAKE2B c4d20a71a4ca313e7fb8550aa89c6abd4d151cf5d27e4d704fcd9cf6a42f542b3b7b749006893ed5dad8f181c6c2102f5232be199d3f1f88d958a2c21b977f02 SHA512 1a47ee7de6fecee8922509898eb752b969cf29200fc74d133d53720c9c519031bdce0ef63d5ad2a99c82868598fb64145bd0dff8d8791b0080b76f6eccb92bf2
MISC metadata.xml 356 BLAKE2B bcffe50af78659801374955b8bb13970760d0d565c89a210d2ee98059078df0bbd5634e95f2cbc9e922e8b29f21cacb7b6339b6004ac4619b21706b7da85be14 SHA512 7cea09fe7cfe3d43572ab13f83921cd252cb4a12bfc9fb4e2629cbd96c90a07fef8613090514ad562ee112960f88bdcbbe18daa185470780bd714e95aa6bfb47
diff --git a/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild b/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..c8f3df726e12
--- /dev/null
+++ b/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils
+
+DESCRIPTION="Generative art image evolver"
+HOMEPAGE="
+ https://sourceforge.net/projects/evolvotron/
+"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+"
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ BUGS NEWS README TODO USAGE
+)
+HTML_DOCS=(
+ evolvotron.html
+)
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ eqmake5 main.pro
+}
+
+src_compile() {
+ local etsubdir
+ for etsubdir in \
+ libfunction libevolvotron evolvotron evolvotron_render evolvotron_mutate
+ do
+ emake sub-${etsubdir}
+ done
+}
+
+src_install() {
+ local bin
+ for bin in ${PN}{,_mutate,_render}; do
+ dobin ${bin}/${bin}
+ done
+ doman man/man1/*
+ einstalldocs
+}
diff --git a/x11-misc/evolvotron/evolvotron-0.7.1.ebuild b/x11-misc/evolvotron/evolvotron-0.7.1.ebuild
index dd964488f2e3..62f289f61def 100644
--- a/x11-misc/evolvotron/evolvotron-0.7.1.ebuild
+++ b/x11-misc/evolvotron/evolvotron-0.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,6 +19,7 @@ RDEPEND="
dev-libs/boost:=
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
dev-qt/qtxml:5
"
DEPEND="${RDEPEND}"