summaryrefslogtreecommitdiff
path: root/x11-misc/dunst/dunst-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/dunst/dunst-9999.ebuild')
-rw-r--r--x11-misc/dunst/dunst-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/x11-misc/dunst/dunst-9999.ebuild b/x11-misc/dunst/dunst-9999.ebuild
index 20a5d5412e6f..f69ffaa99763 100644
--- a/x11-misc/dunst/dunst-9999.ebuild
+++ b/x11-misc/dunst/dunst-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit git-r3 systemd toolchain-funcs
+inherit git-r3 shell-completion systemd toolchain-funcs
EGIT_REPO_URI="https://github.com/dunst-project/dunst"
@@ -12,7 +12,6 @@ HOMEPAGE="https://dunst-project.org/ https://github.com/dunst-project/dunst"
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
IUSE="wayland"
DEPEND="
@@ -75,9 +74,13 @@ src_install() {
emake "${myemakeargs[@]}" install
- insinto /usr/share/zsh/site-functions
- newins contrib/_dunst.zshcomp _dunst
- newins contrib/_dunstctl.zshcomp _dunstctl
+ newbashcomp completions/dunst.bashcomp dunst
+ newbashcomp completions/dunstctl.bashcomp dunstctl
+ newfishcomp completions/dunst.fishcomp dunst
+ newfishcomp completions/dunstctl.fishcomp dunstctl
+ newfishcomp completions/dunstify.fishcomp dunstify
+ newzshcomp completions/_dunst.zshcomp _dunst
+ newzshcomp completions/_dunstctl.zshcomp _dunstctl
systemd_newuserunit dunst.systemd.service.in dunst.service
}