summaryrefslogtreecommitdiff
path: root/x11-misc/compose-tables
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/compose-tables')
-rw-r--r--x11-misc/compose-tables/Manifest3
-rw-r--r--x11-misc/compose-tables/compose-tables-1.7.0.ebuild41
-rw-r--r--x11-misc/compose-tables/metadata.xml11
3 files changed, 55 insertions, 0 deletions
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
new file mode 100644
index 000000000000..acf8e5e1adc3
--- /dev/null
+++ b/x11-misc/compose-tables/Manifest
@@ -0,0 +1,3 @@
+DIST libX11-1.7.0.tar.bz2 2409144 BLAKE2B 1eb6aa8f2fe50ddb2f6d324429b3d9cecfb48833c3f52f22ae8e32846be614c8db63c57d25e2b1c46612b6b333ff61ceab8ac0b605b117bcea1224f918af8e6d SHA512 f661ca90350fd8a94f054b00f12f5122cea068ebff706acfd399462236c189a296a2358d17d16166635101cf56cc19303dd407873a159932d093c9f33556f9fb
+EBUILD compose-tables-1.7.0.ebuild 896 BLAKE2B 8c9361d90be16f2dbdeec75f29e9e9f0e129fa20922c11147d363dcbc23b8747093954ca9b5c914cac9e75c2573261ac043a3ed3253fa5015e0020067345fda0 SHA512 ca1ba19ede5a08d303a9421b529b1e96b68fb30824d3da7b4cd89cfe7728003dae5a656bbfa0886894ea8a2c66a679dc47aa513fc025780f8022b9f146a8f774
+MISC metadata.xml 311 BLAKE2B 1e5deaa311245a5794e72574f94028f60c1c712a06820551cae811b113d633816a60fd3920ff5f2ca287558dbcff28e57537d5c0d3ee3a325c7540bc0b98da13 SHA512 760d09a1ed93bf16d8e26a70fa1178c02c6b336dff9aa29f900d5eff305686b9c3fae4bc93bcce58c0427f567d3759dd3a8adcd8707d07fdd90c6db79d4e13f2
diff --git a/x11-misc/compose-tables/compose-tables-1.7.0.ebuild b/x11-misc/compose-tables/compose-tables-1.7.0.ebuild
new file mode 100644
index 000000000000..252ac5809af1
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_STATIC=no
+XORG_MULTILIB=no
+inherit xorg-3
+
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+DESCRIPTION="X.Org Compose Key tables from libX11"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+RDEPEND="!<x11-libs/libX11-1.7.0"
+
+XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+)
+
+src_compile() {
+ emake -C nls
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}
+
+src_test() {
+ :;
+}
diff --git a/x11-misc/compose-tables/metadata.xml b/x11-misc/compose-tables/metadata.xml
new file mode 100644
index 000000000000..e1e8e6f760c3
--- /dev/null
+++ b/x11-misc/compose-tables/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+</maintainer>
+<upstream>
+ <remote-id type="cpe">cpe:/a:x.org:libx11</remote-id>
+</upstream>
+</pkgmetadata>