summaryrefslogtreecommitdiff
path: root/x11-misc/colord
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/colord')
-rw-r--r--x11-misc/colord/Manifest1
-rw-r--r--x11-misc/colord/colord-1.4.5-r2.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/x11-misc/colord/Manifest b/x11-misc/colord/Manifest
index 7953c1c9c323..212e62dc8f19 100644
--- a/x11-misc/colord/Manifest
+++ b/x11-misc/colord/Manifest
@@ -4,4 +4,5 @@ DIST colord-1.3.5.tar.xz 1263488 BLAKE2B de70f3f76e81d3cec826f444e4c6a1603c03b7d
DIST colord-1.4.5.tar.xz 1869084 BLAKE2B 34c886bade6f71b0b81bbed216695d839873fba46423f6422b80ef2f62e88a403edd1686bb705ef78bcaeb352477e0581d784ccd388961cd42d880661b4b31ab SHA512 b6cc8087ceff4a99b7d764087208cc72e1219d9f6bb52bd3e3eb13bb62e3c1e99aefef36237dceff46925ab7680c76795f59057b7a4d1c8a123de6270708e03c
EBUILD colord-1.3.5.ebuild 5020 BLAKE2B 0bf726b3dceb24289e27ff1db60e5bf02fa350b52e271539a101cb422d2beaa4a4014e2421c8842755d65991e4c26651234ecb0e15ffe3d0659fe51d9f436e85 SHA512 7d2050a8f9bd884498770ace429edc8c3fffa556f9bcd3861e17531988112b6e461a6b76cd0a1eb2d3ad95f1e01d493416ead82faa2aefcfd3a92ce6833a2805
EBUILD colord-1.4.5-r1.ebuild 3362 BLAKE2B fac295c2ae929d47d80b426043ac8ebcd30d29461f6032414af3d5d2404e487fc252041a503a7018e38941fd05b21a5a09db93d10093a59bbee6df0415f0ae19 SHA512 521c737cfc88d5808b64cf9128f4e057e22a94d1d9f7d0075f4e25545606ba0a21ded58197c44969a659b34a63460dec957f5b4a57c6191a9f90a2b68a6f5178
+EBUILD colord-1.4.5-r2.ebuild 3454 BLAKE2B 06653ff22f4096371700c62527013d7742e2272b3b5a29872276c4f289716e8d8d9c8e015b9e11b6d335740a22643c25c586e76529d94e79187c5d00dd3d2bca SHA512 03eae44f5d66575ca404ef2b70c61da3a2d3b682a60b33498825dc2262c509d788c8425d7f2adc96058d884021221e3c62a55a4b299c7a2f096b6b069249dd76
MISC metadata.xml 564 BLAKE2B 6c9696bb5409ed3921ad80067ffbc00b3c01467d97febf58ca776e1f2edb8d58db07578008dc22d6d2670b2647cb4b95310db7333a868e6d7bdd4ba01e89efba SHA512 de1e9a83f335943a893d56d894a46a15739e61123a08808c7a9b5425a419d1f5ca59494297ccab77d68545ef98a65adca10c6715173936db5787f0f49b7faeca
diff --git a/x11-misc/colord/colord-1.4.5-r2.ebuild b/x11-misc/colord/colord-1.4.5-r2.ebuild
new file mode 100644
index 000000000000..2b58d928279d
--- /dev/null
+++ b/x11-misc/colord/colord-1.4.5-r2.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit bash-completion-r1 meson-multilib vala
+
+DESCRIPTION="System service to accurately color manage input and output devices"
+HOMEPAGE="https://www.freedesktop.org/software/colord/"
+SRC_URI="https://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/2" # subslot = libcolord soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="gtk-doc argyllcms examples extra-print-profiles +introspection scanner systemd test vala"
+RESTRICT="!test? ( test ) test" # Tests try to read and write files in /tmp
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.58.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/lcms-2.6:2=[${MULTILIB_USEDEP}]
+ dev-db/sqlite:3=[${MULTILIB_USEDEP}]
+ >=dev-libs/libgusb-0.2.7[introspection?,${MULTILIB_USEDEP}]
+
+ dev-libs/libgudev:=[${MULTILIB_USEDEP}]
+ virtual/libudev:=[${MULTILIB_USEDEP}]
+ virtual/udev
+
+ systemd? ( >=sys-apps/systemd-44:0= )
+ scanner? (
+ media-gfx/sane-backends
+ sys-apps/dbus
+ )
+ >=sys-auth/polkit-0.114
+ argyllcms? ( media-gfx/argyllcms )
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+"
+RDEPEND="${DEPEND}
+ acct-group/colord
+ acct-user/colord
+"
+BDEPEND="
+ acct-group/colord
+ acct-user/colord
+ app-text/docbook-xsl-ns-stylesheets
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ extra-print-profiles? ( media-gfx/argyllcms )
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-tests-Don-t-use-exact-floating-point-comparisons.patch
+ "${FILESDIR}"/${PV}-optional-introspection.patch
+)
+
+src_prepare() {
+ default
+ use vala && vala_src_prepare
+
+ # Test requires a running session
+ # https://github.com/hughsie/colord/issues/94
+ sed -i -e "/test('colord-test-daemon'/d" lib/colord/meson.build || die
+
+ # Adapt to Gentoo paths
+ sed -i \
+ -e "s|find_program('spotread'|find_program('argyll-spotread'|" \
+ -e "s|find_program('colprof'|find_program('argyll-colprof'|" \
+ meson.build || die
+
+ # meson gnome.generate_vapi properly handles VAPIGEN and other vala
+ # environment variables. It is counter-productive to check for an
+ # unversioned vapigen, as that breaks versioned VAPIGEN usages.
+ sed -i -e "/find_program('vapigen')/d" meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_true daemon)
+ -Dbash_completion=false
+ $(meson_native_true udev_rules) # Install udev rules only from native build
+ $(meson_native_use_bool systemd)
+ -Dlibcolordcompat=true
+ $(meson_native_use_bool argyllcms argyllcms_sensor)
+ -Dreverse=false
+ $(meson_native_use_bool scanner sane)
+ $(meson_native_use_bool introspection)
+ $(meson_native_use_bool vala vapi)
+ $(meson_native_use_bool extra-print-profiles print_profiles)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ -Ddaemon_user=colord
+ $(meson_native_true man)
+ $(meson_use gtk-doc docs)
+ --localstatedir="${EPREFIX}"/var
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ newbashcomp data/colormgr colormgr
+
+ # Ensure config and profile directories exist and /var/lib/colord/*
+ # is writable by colord user
+ keepdir /var/lib/color{,d}/icc
+ fowners colord:colord /var/lib/colord{,/icc}
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}