summaryrefslogtreecommitdiff
path: root/x11-misc/colord/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/colord/files')
-rw-r--r--x11-misc/colord/files/colord-1.4.6-FILE_OFFSET_BITS.patch38
-rw-r--r--x11-misc/colord/files/colord-1.4.6-lcms2-corruption.patch33
-rw-r--r--x11-misc/colord/files/colord-1.4.6-time_t-ptr-truncation.patch35
3 files changed, 0 insertions, 106 deletions
diff --git a/x11-misc/colord/files/colord-1.4.6-FILE_OFFSET_BITS.patch b/x11-misc/colord/files/colord-1.4.6-FILE_OFFSET_BITS.patch
deleted file mode 100644
index c41f73e4eb8a..000000000000
--- a/x11-misc/colord/files/colord-1.4.6-FILE_OFFSET_BITS.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-https://github.com/hughsie/colord/pull/159
-
-From 72cc7bb299de09ec53aa4ce125af370158127d0e Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Sat, 2 Dec 2023 05:07:46 +0000
-Subject: [PATCH] meson.build: set FILE_OFFSET_BITS explicitly
-
-This is needed if building introspection because:
-a) Meson's own setting of FILE_OFFSET_BITS (which it does by default) doesn't
-affect the introspection tooling;
-
-b) glibc's headers seem to react poorly to _just_ _TIME_BITS being set, even
-though in this cas, the failure was for a 64-bit ABI anyway.
-
-Fixes: ce9732a87bc2a0ddca841b49b9b9e24351ea78c8
-Signed-off-by: Sam James <sam@gentoo.org>
----
- meson.build | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 072a612..b0b1af8 100644
---- a/meson.build
-+++ b/meson.build
-@@ -215,7 +215,9 @@ add_project_arguments('-DCD_COMPILATION', language: 'c')
- # Needed for realpath() and PATH_MAX
- add_project_arguments('-D_XOPEN_SOURCE=700', language : 'c')
- # Needed to opt-in to 64-bit time_t on glibc. We pass 64-bit pointers into
--# gmtime_r.
-+# gmtime_r. We have to set F_O_B here despite Meson defaulting to it because
-+# it doesn't get passed down to introspection otherwise.
-+add_project_arguments('-D_FILE_OFFSET_BITS=64', language : 'c')
- add_project_arguments('-D_TIME_BITS=64', language : 'c')
-
- prefix = get_option('prefix')
---
-2.43.0
-
diff --git a/x11-misc/colord/files/colord-1.4.6-lcms2-corruption.patch b/x11-misc/colord/files/colord-1.4.6-lcms2-corruption.patch
deleted file mode 100644
index 4df6773cfb4b..000000000000
--- a/x11-misc/colord/files/colord-1.4.6-lcms2-corruption.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-https://bugs.gentoo.org/880865
-
-https://github.com/mm2/Little-CMS/issues/344
-https://github.com/hughsie/colord/issues/145
-
-https://github.com/hughsie/colord/commit/91a3cc2e994be587def3b70762f15461101d43a1
-
-From 91a3cc2e994be587def3b70762f15461101d43a1 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Tue, 15 Nov 2022 17:03:37 +0000
-Subject: [PATCH] lib: avoid destructing LCMS plugin twice with lcms 2.14
-
-lcms 2.14 contains a change to avoid a memory leak, but that change
-assumes correct API usage. It's not necessary to both cmsUnregisterPluginsTHR()
-and then cmsDeleteContext() -- we can just straight up delete the LCMS
-context instead (cmsDeleteContext()).
-
-So, follow upstream's suggestion & do that. This fixes memory corruption
-when building colord on x86, for example.
-
-Bug: https://github.com/mm2/Little-CMS/issues/344
-Fixes: https://github.com/hughsie/colord/issues/145
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/lib/colord/cd-context-lcms.c
-+++ b/lib/colord/cd-context-lcms.c
-@@ -163,7 +163,6 @@ cd_context_lcms_free (gpointer ctx)
- g_clear_error (error_ctx);
- g_free (error_ctx);
-
-- cmsUnregisterPluginsTHR (ctx);
- cmsDeleteContext (ctx);
- }
-
diff --git a/x11-misc/colord/files/colord-1.4.6-time_t-ptr-truncation.patch b/x11-misc/colord/files/colord-1.4.6-time_t-ptr-truncation.patch
deleted file mode 100644
index 687b595feca5..000000000000
--- a/x11-misc/colord/files/colord-1.4.6-time_t-ptr-truncation.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-https://bugs.gentoo.org/918990
-https://github.com/hughsie/colord/issues/157
-https://github.com/hughsie/colord/commit/ce9732a87bc2a0ddca841b49b9b9e24351ea78c8
-
-From ce9732a87bc2a0ddca841b49b9b9e24351ea78c8 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Fri, 1 Dec 2023 22:20:17 +0000
-Subject: [PATCH] meson.build: use 64-bit time_t
-
-We call `gmtime_r` (which expects `time_t`) with a 64-bit pointer (`gint64*`).
-
-On 32-bit systems, `time_t` is 32-bit unless you opt-in to a 64-bit wide version
-(at least on glibc). To avoid truncation and -Wincompatible-pointer-types,
-opt-in to 64-bit `time_t` for glibc with `-D_TIME_BITS=64` in meson.
-
-This should be fine ABI wise because the time is only passed down into lcms2
-into `_cmsEncodeDateTimeNumber` where it seems to decompose it and it worked already
-for 64-bit systems. Plus, they use their own types like `cmsUInt16Number` to ensure
-they're wide enough.
-
-Fixes: https://github.com/hughsie/colord/issues/157
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/meson.build
-+++ b/meson.build
-@@ -214,6 +214,9 @@ add_project_arguments('-DCD_COMPILATION', language: 'c')
-
- # Needed for realpath() and PATH_MAX
- add_project_arguments('-D_XOPEN_SOURCE=700', language : 'c')
-+# Needed to opt-in to 64-bit time_t on glibc. We pass 64-bit pointers into
-+# gmtime_r.
-+add_project_arguments('-D_TIME_BITS=64', language : 'c')
-
- prefix = get_option('prefix')
-
-