summaryrefslogtreecommitdiff
path: root/x11-misc/colord/colord-1.4.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/colord/colord-1.4.6.ebuild')
-rw-r--r--x11-misc/colord/colord-1.4.6.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-misc/colord/colord-1.4.6.ebuild b/x11-misc/colord/colord-1.4.6.ebuild
index e549989e284e..6b1521b25a0a 100644
--- a/x11-misc/colord/colord-1.4.6.ebuild
+++ b/x11-misc/colord/colord-1.4.6.ebuild
@@ -4,7 +4,7 @@
EAPI=7
VALA_USE_DEPEND="vapigen"
-inherit bash-completion-r1 meson-multilib tmpfiles vala
+inherit bash-completion-r1 meson-multilib tmpfiles udev vala
DESCRIPTION="System service to accurately color manage input and output devices"
HOMEPAGE="https://www.freedesktop.org/software/colord/"
@@ -12,7 +12,7 @@ SRC_URI="https://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
LICENSE="GPL-2+"
SLOT="0/2" # subslot = libcolord soname version
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~sparc x86"
IUSE="gtk-doc argyllcms examples extra-print-profiles +introspection scanner selinux systemd test vala"
RESTRICT="!test? ( test ) test" # Tests try to read and write files in /tmp
@@ -114,5 +114,10 @@ multilib_src_install_all() {
}
pkg_postinst() {
+ udev_reload
tmpfiles_process colord.conf
}
+
+pkg_postrm() {
+ udev_reload
+}