summaryrefslogtreecommitdiff
path: root/x11-misc/autorandr
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/autorandr')
-rw-r--r--x11-misc/autorandr/Manifest4
-rw-r--r--x11-misc/autorandr/autorandr-1.15.ebuild76
-rw-r--r--x11-misc/autorandr/autorandr-9999.ebuild6
3 files changed, 82 insertions, 4 deletions
diff --git a/x11-misc/autorandr/Manifest b/x11-misc/autorandr/Manifest
index 2d8b1f2a86bf..654344e371f6 100644
--- a/x11-misc/autorandr/Manifest
+++ b/x11-misc/autorandr/Manifest
@@ -1,6 +1,8 @@
DIST autorandr-1.13.3.tar.gz 47630 BLAKE2B fb53316af4d3fa399f278be874e95d06cbd188bebf1e22793ca30ad4f9a8817674390c7d02d501f4a35a0a6f23b16202e97f2a6559727e67e908d21121de8a56 SHA512 6c3f99da52a029a8f1717020ebafbd7afb58d97651776a6620f47e299584704ab65c37be5e9497cca3c53d6268ebde11481f32967ec289adf606a73e587e874f
DIST autorandr-1.14.tar.gz 49234 BLAKE2B 3ff149d30b023bc54d83c4be1f81f67204d20d3e6a7a43e15009c1c4f1180fa920789ce84ae56f13946a9cec1f72bc7adb27be3c58ca8532235d0457b1f5aa92 SHA512 dc1ee4c28b06dde4a721fe564734e7a79c1c843986f7c84307ea60f19c2237ba53d1bcd2202e377363e7e0a5bf5dea95bea4490b3fa5ec5fa6738114646a502d
+DIST autorandr-1.15.tar.gz 49352 BLAKE2B b7200eb7a77230076f1a9f8b1a21be883ae363cc41cff7f1191e034359cc8ebb52e9dd19dd5f2e415a34b9a3a89fda3d0d43a946b2f3401de0d279fb9d5ba1a2 SHA512 2837348b755f5c4b30ad2b68e191e1969a467401cf32dda495dd19867e391f8b8b4a9c0b4958ef33f75c71aace46686995e27bab805e1e40cc4a1af44e9f0405
EBUILD autorandr-1.13.3.ebuild 1507 BLAKE2B a1f749c6298eb9f42d3e714ff5039667b9991a1c9e32b589c3019d779b9ac64b982d4d33c3f23eb133fb98253a944550a06fda5a281f06e3bbe3f2dbdc90ae52 SHA512 d7ae39c907788956ffe55757f93d113acc2f8dcca03055a7610f6cf05933b72f48e9688a599b545d3db64ad5ea182a373babea1814c31a7800039de828659f57
EBUILD autorandr-1.14.ebuild 1508 BLAKE2B 227d2a419f76b6dab07f9820068f79462c474e51a6989804ad9248ad68acee78234c9e0567e422951dfc765c5c497561b7252b4bd9bd57183d16555b57609ffb SHA512 a9ca635ce495a10023919f016068c46798f455bb244dea53fb477d6b349166ff80ecb0e7d0da653884ea73228264076f531cc97e097c845a7698a9cc71018c23
-EBUILD autorandr-9999.ebuild 1509 BLAKE2B 38fdd65595ae46310629c7f40bf3a56820999f8838194e41871377bc49663f1bc497c034c26c70d44fe8642bdc2a8a9d8448a6a88a39f3a9cf4d0c4d1c2b0612 SHA512 331b770efe9b3945c8bf964d7c7a91c5d734b58209db6b757baf3253863204eb20c262d927b9cfda504fa1a6a843750c66b081a0e7c1752b6dfdcec12f47d50c
+EBUILD autorandr-1.15.ebuild 1505 BLAKE2B bef056ebbb659c97915085e12903f92a9d9400720fa06a8b6bae8e45775886409fadecb5f353e146d03eaed02c2ba07b38dba307158528ef58fea196af9c07b2 SHA512 51fc370e0a5f36f64268a5332597fdd25b0f5c4fa2eaaebb786c60019b82dc9f7185e5e2defc1bbaa7ec92b5aad1d6edbd91b5984a1e7f467acfcc558a62e6ae
+EBUILD autorandr-9999.ebuild 1505 BLAKE2B bef056ebbb659c97915085e12903f92a9d9400720fa06a8b6bae8e45775886409fadecb5f353e146d03eaed02c2ba07b38dba307158528ef58fea196af9c07b2 SHA512 51fc370e0a5f36f64268a5332597fdd25b0f5c4fa2eaaebb786c60019b82dc9f7185e5e2defc1bbaa7ec92b5aad1d6edbd91b5984a1e7f467acfcc558a62e6ae
MISC metadata.xml 450 BLAKE2B bb36360893882faa3306ce69953a4c699e613dd5608bd379c3a179cd68d79ce42171c01611fb08269b9521eca61c67825ea1d52711a0ac67fa99f919350b54bd SHA512 d676779669537dff4c0964d48996b3cdcbc1b6d7f3f00412b48614f42b86b6acdea05b646d3d9d048db6b19e0733bbc1281ed8dbea7d4ea36f19f14c5a055d29
diff --git a/x11-misc/autorandr/autorandr-1.15.ebuild b/x11-misc/autorandr/autorandr-1.15.ebuild
new file mode 100644
index 000000000000..0011c189d5ca
--- /dev/null
+++ b/x11-misc/autorandr/autorandr-1.15.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 systemd udev
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
+else
+ SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Automatically select a display configuration based on connected devices"
+HOMEPAGE="https://github.com/phillipberndt/autorandr"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="launcher systemd udev"
+
+RDEPEND="
+ x11-apps/xrandr
+ launcher? ( x11-libs/libxcb )
+ udev? ( virtual/udev )
+"
+DEPEND="${RDEPEND}"
+# desktop-file-util: uses desktop-file-edit in Makefile
+BDEPEND="
+ dev-util/desktop-file-utils
+ virtual/pkgconfig
+"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use launcher; then
+ emake contrib/autorandr_launcher/autorandr-launcher
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman autorandr.1
+
+ local targets=(
+ autostart_config
+ bash_completion
+ $(usev launcher)
+ $(usev systemd)
+ $(usev udev)
+ )
+
+ emake DESTDIR="${D}" \
+ BASH_COMPLETIONS_DIR="$(get_bashcompdir)" \
+ SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ $(printf "install_%s " "${targets[@]}")
+}
+
+pkg_postinst() {
+ if use udev; then
+ udev_reload
+ fi
+}
+
+pkg_postrm() {
+ if use udev; then
+ udev_reload
+ fi
+}
diff --git a/x11-misc/autorandr/autorandr-9999.ebuild b/x11-misc/autorandr/autorandr-9999.ebuild
index 5a4cdc0e7c9f..0011c189d5ca 100644
--- a/x11-misc/autorandr/autorandr-9999.ebuild
+++ b/x11-misc/autorandr/autorandr-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit bash-completion-r1 distutils-r1 systemd udev
@@ -13,7 +13,7 @@ if [[ "${PV}" = "9999" ]] ; then
EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
else
SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="Automatically select a display configuration based on connected devices"