summaryrefslogtreecommitdiff
path: root/x11-misc/autorandr/autorandr-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/autorandr/autorandr-9999.ebuild')
-rw-r--r--x11-misc/autorandr/autorandr-9999.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/x11-misc/autorandr/autorandr-9999.ebuild b/x11-misc/autorandr/autorandr-9999.ebuild
index 0badb8f708aa..7f0dd9c1da1b 100644
--- a/x11-misc/autorandr/autorandr-9999.ebuild
+++ b/x11-misc/autorandr/autorandr-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
inherit bash-completion-r1 distutils-r1 systemd udev
@@ -63,3 +64,9 @@ pkg_postinst() {
udev_reload
fi
}
+
+pkg_postrm() {
+ if use udev; then
+ udev_reload
+ fi
+}