summaryrefslogtreecommitdiff
path: root/x11-misc/alacarte/alacarte-3.44.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/alacarte/alacarte-3.44.2.ebuild')
-rw-r--r--x11-misc/alacarte/alacarte-3.44.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/alacarte/alacarte-3.44.2.ebuild b/x11-misc/alacarte/alacarte-3.44.2.ebuild
new file mode 100644
index 000000000000..ec98922c90ce
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-3.44.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${DEPEND}
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}