summaryrefslogtreecommitdiff
path: root/x11-misc/3ddesktop/3ddesktop-0.2.9-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/3ddesktop/3ddesktop-0.2.9-r2.ebuild')
-rw-r--r--x11-misc/3ddesktop/3ddesktop-0.2.9-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/3ddesktop/3ddesktop-0.2.9-r2.ebuild b/x11-misc/3ddesktop/3ddesktop-0.2.9-r2.ebuild
new file mode 100644
index 000000000000..199878c516f1
--- /dev/null
+++ b/x11-misc/3ddesktop/3ddesktop-0.2.9-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="OpenGL virtual desktop switching"
+HOMEPAGE="https://sourceforge.net/projects/desk3d/"
+SRC_URI="mirror://sourceforge/desk3d/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=media-libs/freetype-2
+ media-libs/freeglut
+ media-libs/imlib2[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+DOCS=( AUTHORS TODO ChangeLog README README.windowmanagers )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc4.patch
+ "${FILESDIR}"/${P}-asneeded.patch
+ "${FILESDIR}"/${P}-missing-include.patch
+ "${FILESDIR}"/${P}-gl_init.patch
+ "${FILESDIR}"/${P}-Options_Options.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ echo
+ elog "This ebuild installed a configuration file called /etc/3ddesktop.conf"
+ elog "The default configuration makes a screenshot of the virtual desktops"
+ elog "every X seconds. This is non-optimal behavior."
+ elog
+ elog "To enable a more intelligent way of updating the virtual desktops,"
+ elog "execute the following:"
+ elog
+ elog " echo \"AutoAcquire 0\" >> /etc/3ddesktop.conf"
+ elog
+ elog "This will cause 3ddesktop to update the virtual desktop snapshots"
+ elog "only when a 3d desktop switch is required."
+}