summaryrefslogtreecommitdiff
path: root/x11-libs/wxGTK/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/wxGTK/files')
-rw-r--r--x11-libs/wxGTK/files/wxGTK-3.0.5.1-configure-modern-c.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-libs/wxGTK/files/wxGTK-3.0.5.1-configure-modern-c.patch b/x11-libs/wxGTK/files/wxGTK-3.0.5.1-configure-modern-c.patch
new file mode 100644
index 000000000000..6512c6329efb
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxGTK-3.0.5.1-configure-modern-c.patch
@@ -0,0 +1,54 @@
+https://github.com/wxWidgets/wxWidgets/commit/da4b42688a6cd5444eefb91bf40183d88203ffca
+https://bugs.gentoo.org/874441
+--- a/configure
++++ b/configure
+@@ -19586,6 +19586,7 @@ else
+ /* end confdefs.h. */
+
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {
+@@ -22300,6 +22301,7 @@ else
+
+ #include <zlib.h>
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {
+@@ -22422,6 +22424,7 @@ else
+
+ #include <png.h>
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {
+--- a/configure.in
++++ b/configure.in
+@@ -1482,6 +1482,7 @@ case "${host}" in
+ dnl Check the gcc version macro.
+ [
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {
+@@ -2439,6 +2440,7 @@ if test "$wxUSE_ZLIB" != "no" ; then
+ [
+ #include <zlib.h>
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {
+@@ -2507,6 +2509,7 @@ if test "$wxUSE_LIBPNG" != "no" ; then
+ [
+ #include <png.h>
+ #include <stdio.h>
++ #include <stdlib.h>
+
+ int main()
+ {