summaryrefslogtreecommitdiff
path: root/x11-libs/libxcb
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libxcb')
-rw-r--r--x11-libs/libxcb/Manifest2
-rw-r--r--x11-libs/libxcb/files/libxcb-1.16-Enable-large-file-support.patch25
-rw-r--r--x11-libs/libxcb/libxcb-1.16-r1.ebuild66
3 files changed, 93 insertions, 0 deletions
diff --git a/x11-libs/libxcb/Manifest b/x11-libs/libxcb/Manifest
index 0c80e22f18bd..f84117ef0d4a 100644
--- a/x11-libs/libxcb/Manifest
+++ b/x11-libs/libxcb/Manifest
@@ -1,3 +1,5 @@
+AUX libxcb-1.16-Enable-large-file-support.patch 683 BLAKE2B e3c2b8449377681beabfae75d3354a1d3f40d08c62184d1f0ce607a11a615c835c8fcd746523db5e6c2c029aaa636ec3856f73c46ecbcc24b44fd40e400eeda1 SHA512 1b1545f97ea10d1b24d6a6204a0252158e81f60352408349a2ed5883479c4858a444ad77b225db55528e62b209bafd03df8fb5028a2ab9633acf1ec875f3d5c0
DIST libxcb-1.16.tar.xz 452964 BLAKE2B 1ddd5c2e6be8400a0a77db4b5fbd4698996fd1a00984e370b1f712f6b9ce456c8ccfb6992f2973f5eaf8d5b6b75f39b9f51a1458c2432ddb41edd8199b91b3f9 SHA512 002fbc126c6f09eb7db5e4197cd0572d495f64b6de714a76d9a024fe3e13122c1cfc7c55207c0dee76cc63fcccf87b37db513223eadaf760af2bd2a926443bf8
+EBUILD libxcb-1.16-r1.ebuild 1529 BLAKE2B 8db61f6b9d7f099d30a2b1f67aff9bb09009bf1119b9c66821c9e4f907cd6f28eba9f6b0d7c632b4e27e8228b0adb8a6323470ca89954750eb588bda642dac0a SHA512 f36a9ea9b4ffc6c274569566b7d7955fac9747b99bdc4d241126f83036264c788c1d400e408b389934a9d97efc2219b491e40a011d4e6d2edb25888e4c9e5bfd
EBUILD libxcb-1.16.ebuild 1379 BLAKE2B 8affdafdf45fb747abab54c53ec2faf0db7002b98a3be9ddf5648247b7a3a0a10cf582177c8557771ada7128d3f01daf56eb6e22b29765ebdcd42066b5e6fdea SHA512 00eb1cf63973c420000428b7e1749b2f56b0b087bf73c8ca784c547d11eac9ae0678e684b0d1a86ec261c487308c604b4b75da81d98644dece76db3bef864b24
MISC metadata.xml 470 BLAKE2B 9f530dabef12ece5a3ccaade8000872e1a89cfef4833ca4d6a4c5e157510516fec18f18e7dbe4ae88ac4059acff9fd099832c3614d12d9742af03167def25f16 SHA512 884ca6cde9de9394a67493b5ec40475873e363ad2530470ebbc0e080f55594bf02787b02960ad172ba05e736c80a6b9c33aa9c2ceaf1b47005f6f47b0895c1a3
diff --git a/x11-libs/libxcb/files/libxcb-1.16-Enable-large-file-support.patch b/x11-libs/libxcb/files/libxcb-1.16-Enable-large-file-support.patch
new file mode 100644
index 000000000000..c1c8ad5dc05c
--- /dev/null
+++ b/x11-libs/libxcb/files/libxcb-1.16-Enable-large-file-support.patch
@@ -0,0 +1,25 @@
+From 3c946010c8521497b0fba2c8bc9bde184622345a Mon Sep 17 00:00:00 2001
+From: Fergus Dall <sidereal@google.com>
+Date: Tue, 7 Nov 2023 17:42:42 +1100
+Subject: [PATCH libxcb] Enable large file support
+
+Signed-off-by: Fergus Dall <sidereal@google.com>
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configure.ac b/configure.ac
+index b78454d..d981bea 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,6 +18,7 @@ AM_PATH_PYTHON([3.0])
+ # Must be called before any macros that run the compiler (like AC_PROG_LIBTOOL)
+ # to avoid autoconf errors.
+ AC_USE_SYSTEM_EXTENSIONS
++AC_SYS_LARGEFILE
+
+ # Initialize libtool
+ LT_PREREQ([2.2])
+--
+2.42.0.869.gea05f2083d-goog
+
diff --git a/x11-libs/libxcb/libxcb-1.16-r1.ebuild b/x11-libs/libxcb/libxcb-1.16-r1.ebuild
new file mode 100644
index 000000000000..abb75e7b35a6
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.16-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+XORG_TARBALL_SUFFIX="xz"
+XORG_MULTILIB=yes
+XORG_DOC=doc
+
+inherit python-any-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc selinux test +xkb"
+RESTRICT="!test? ( test )"
+SLOT="0/1.12"
+
+RDEPEND="
+ >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ >=x11-base/xcb-proto-1.16.0
+ elibc_Darwin? ( dev-libs/libpthread-stubs )
+ test? ( dev-libs/check[${MULTILIB_USEDEP}] )
+"
+# Note: ${PYTHON_USEDEP} needs to go verbatim
+BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '>=x11-base/xcb-proto-1.16.0[${PYTHON_USEDEP}]')
+ doc? ( app-doc/doxygen[dot] )
+ test? ( dev-libs/libxslt )
+ >=x11-misc/util-macros-1.18
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.16-Enable-large-file-support.patch"
+)
+
+python_check_deps() {
+ python_has_version ">=x11-base/xcb-proto-1.16.0[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc devel-docs)
+ $(use_enable selinux)
+ )
+ xorg-3_src_configure
+}