summaryrefslogtreecommitdiff
path: root/x11-libs/libast/libast-0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libast/libast-0.7.ebuild')
-rw-r--r--x11-libs/libast/libast-0.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-libs/libast/libast-0.7.ebuild b/x11-libs/libast/libast-0.7.ebuild
new file mode 100644
index 000000000000..9704b6719355
--- /dev/null
+++ b/x11-libs/libast/libast-0.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="LIBrary of Assorted Spiffy Things"
+HOMEPAGE="http://www.eterm.org/download/"
+SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="imlib cpu_flags_x86_mmx pcre"
+
+RDEPEND="!sci-astronomy/ast
+ x11-libs/libXt
+ x11-proto/xproto
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ =media-libs/freetype-2*
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ local myregexp="posix"
+ use pcre && myregexp="pcre"
+ econf \
+ $(use_with imlib) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ --with-regexp=${myregexp} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README DESIGN ChangeLog
+}