summaryrefslogtreecommitdiff
path: root/x11-libs/libX11
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libX11')
-rw-r--r--x11-libs/libX11/Manifest2
-rw-r--r--x11-libs/libX11/libX11-1.8.5.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-libs/libX11/Manifest b/x11-libs/libX11/Manifest
index 4f282768d3d5..29632aabb8f2 100644
--- a/x11-libs/libX11/Manifest
+++ b/x11-libs/libX11/Manifest
@@ -1,3 +1,5 @@
DIST libX11-1.8.4.tar.xz 1835316 BLAKE2B f9f5d1b97e8ac6f8f0edc490a270f98ff4fd901c2054c309bce1f1b3eb690704193e18cd470f682c663090210b14a9498b9259b6acc0e902053e7ab0ca9df076 SHA512 3150a47498b0cb012482ee02efeaae16d9e736288f2b3f917be912e1613d56ad6b4ab180de8820305deb2b95dfd993633f43a65344d75979d6b86bdf110cb63e
+DIST libX11-1.8.5.tar.xz 1811288 BLAKE2B 13ccdcec5d3cd31b8be88402aa7821a1d28520e90e454b816abdf773f21da5cc1690eaa4f17c6f34a3f1254e3b6d21a8a38228428cb113f7198d981f39d1c3eb SHA512 5274f6073ead119c8f915d302f1e2bf9579f88d28a2a2d084a4be2050b14fb605efe91099c89ba55aeb7ad36ae0ecbd519b0808be0e29f56367d5dd8faa063d3
EBUILD libX11-1.8.4-r1.ebuild 1006 BLAKE2B 8ea7476bf009cf313eec3224dbe1588b31d2facaf99106b4a5bbf3d8235417c29cb778fe7baea1850a4bf5db4a2aba30c3b89054e79f4296044a16b9a406dc01 SHA512 3e0bea40df7719fbbaaf3080341fbe5947bd79146b114b3f489a07534dd57c9f7314f9e71da68051e4f6d88e3a80edd756bfa31a6632639eb7f8d2aed4edb767
+EBUILD libX11-1.8.5.ebuild 1014 BLAKE2B b5d949580a276b2796227531c292b26e893ad83769d741a2ef45542785b5011ae15e8aef58de97c39b46724514caa0d610bf6e5ade86f019aaa00842ba5fb49e SHA512 409373d45f74cf33ab290b0d5b8376222ed3711ae4e5f8ba2139ab65a72c03df53d145661bbfb35b9604ce579dfcd2fde4aad11ddf4e66efce6378c6e8262ffa
MISC metadata.xml 395 BLAKE2B 7912fcccfd8d8a4c9c1e5601783a0668679506638511ee719bf7bb95f99415fe95a417343060cf5ca3fe918ab1f9847f74861af36d3c712afa321272cd13cf66 SHA512 c2956ef519fe59d0f713732059224568b9d7c34579654b71993b02227a512c1ac3057dc7f81c6bc93834fd4fee212f1ae26f4055ea92f3eb7524da7d9e690f8f
diff --git a/x11-libs/libX11/libX11-1.8.5.ebuild b/x11-libs/libX11/libX11-1.8.5.ebuild
new file mode 100644
index 000000000000..28f7a5710fd8
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.8.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX=xz
+inherit toolchain-funcs xorg-3
+
+# Note: please bump this with x11-misc/compose-tables
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+
+ !<xfce-base/xfce4-settings-4.16.3
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans
+"
+BDEPEND="test? ( dev-lang/perl )"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ --enable-ipv6
+ --without-fop
+ --with-keysymdefdir="${ESYSROOT}/usr/include/X11"
+ CPP="$(tc-getPROG CPP cpp)"
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+ rm -rf "${ED}"/usr/share/X11/locale || die
+}